I am new to Ubuntu and have tried using the Ubuntu Software Center.

It shows up but once it opens it doesn't respond.

Can you help me figure out how to reset this application (Ubuntu Software Center)? Thanks!

  • Has the system asked to install updates? It could be trying to process updates first hence the delay. Have you left it for a while to see if it becomes responsive? – Mordoc Feb 27 '13 at 18:19
  • I just got Ubuntu yesterday though... – user1978786 Feb 27 '13 at 18:25
  • What often works is removing the applications' hidden configuration files in your home folder- i.e in this case ~/.cache/software-center and ~/.config/software-center and then reinstalling software-centre. The advice for this related question also centred around these sorts of suggestions for software-center. – user76204 Feb 27 '13 at 18:38
  • Wy you don't try ubuntu 12.10 instead if your are a newbie to ubuntu? 13.04 is still under development. – Thomas15v Feb 27 '13 at 20:08
  • 1
    Welcome to Ask Ubuntu! Your question relates to an alpha or beta release of Ubuntu. Such questions are generally not within Ask Ubuntu's ambit. Please look at There's an issue with an Alpha/Beta Release of Ubuntu, what should I do? for further assistance. Thanks! – user25656 Feb 28 '13 at 1:56

Open a terminal and type:


Your cursor will turn into an "X" and click on the window that is frozen. It will force kill it.

After which you should run an update to see if there are any new versions of the software.

sudo apt-get update

Hope this helps!

  • I got the update and nothing happened. – user1978786 Feb 27 '13 at 18:42

Run this command in terminal. It will re-install the software-center and reset your settings.

sudo apt-get install --reinstall software-center

But for reconfigure a program you can use:

sudo dpkg-reconfigure software-center --force
  • I tried your answer and when I opened up the software center again it still did not respond!!! – user1978786 Feb 27 '13 at 18:42
  • What happens when you do software-center in terminal? Are you sure there are no apt-get and dpkg processes running? – Thomas15v Feb 27 '13 at 18:46
  • 1
    It reinstalls it but when I restarted my computer and launched the software center but I still did not respond. Please help! – user1978786 Feb 27 '13 at 19:20
  • Did you tried "software-center" in terminal? In the terminal window you can read what is wrong. But maby try the folowing commands "sudo dpkg-reconfigure software-center --force", "sudo apt-get install -f" – Thomas15v Feb 27 '13 at 19:51

To be honest, I'm not sure why anyone new to Ubuntu would be using an unstable development version. There are and will be issues peculiar to 13.04 that the dev team and others are working to resolve, before it's official release date. This might be one of them.

My suggestion would be to wipe 13.04 and install the 12.04LTS version. This will give you the most stable version of Ubuntu, and the version that will be supported for the longest time. It'll also be the best way to learn about Ubuntu & Linux in general. Re-installing is a bit of a drag I know, but for you as a noob it would be well worth the effort. :-)

  • Is there a command I can run on the terminal that can reinstall ubuntu as 12.04 – user1978786 Feb 27 '13 at 20:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.