I have a Lenovo IdeaPad Yoga. It's been working flawlessly with Windows 8 - 9 hour battery life, awesome touchscreen, 4-second boot times.

So obviously I wanted to try Ubuntu 12.10. Well, I downloaded it and installed it - but I couldn't change the brightness!

These hotkeys work in Windows but not in Ubuntu - and none of the solutions others have proposed in other similar questions with Lenovo laptops have worked.

How can I make my brightness hotkeys work?

  • Please tell us which solutions did you try. – To Do Feb 27 '13 at 17:26
  • I found an answer! It shall be posted in 6 hours, as new users can't post answers for 8 hours after the questions's been asked. – Owen Versteeg Feb 27 '13 at 19:08

FOR 12.10

Okay, I found an answer in this page.

This solved my brightness problems permanently:

sudo gedit /etc/default/grub

You will find this line in the new opened window:


Change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Save and close the window and type this in the terminal:

sudo update-grub

and reboot.

FOR 13.04

  1. Add the acpi_backlight=vendor to your grub default command line
  2. Run the update-grub command
  3. blacklist the ideapad_laptop by adding "blacklist ideapad_laptop" to your /etc/modprobe.d/blacklist.conf file.
  4. Reboot
  • 1
    I had precisely this problem on a Lenovo Thinkpad X1 Carbon under Ubuntu 13.04 and the solution solved it. – Marius Hofert Apr 9 '13 at 22:39
  • 1
    Now, on my T430 in Ubuntu 13.04, brightness gets adjusted properly but the brightness level indicator doesn't show the correct value. Anyway... – krlmlr May 23 '13 at 13:38
  • The FOR 13.04 steps also helped me with making the touchpad of my Yoga 11s work directly after boot, not only after a standy-resume detour under Ubuntu 15.10. – ojdo Apr 26 '16 at 20:22

I have another solution:

GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""


sudo update-grub

fixed it for me.

  • Huh, I'll try this when I update to 13.04. Thanks! – Owen Versteeg Apr 16 '13 at 14:12
  • 1
    This worked well for me on my ThinkPad T430, and fits in with the bug discussion on the kernel change which caused it. – Matthew Walton May 5 '13 at 21:35

Another solution for my Lenovo G480:

  1. sudo nano /etc/default/grub

  2. Change the line GRUB_CMDLINE_LINUX="quiet splash" into:

    GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux"

  3. sudo update-grub

  4. Restart your Linux

This fix should work for another Lenovo models.

Not the answer you're looking for? Browse other questions tagged or ask your own question.