I have tried installing the Ubuntu Touch with the Nexus 7 Ubuntu Core installer on Ubuntu 12.10 64bit in a VMWare virtual machine.

It looks like its stuck on Erasing boot partition. I have read elsewhere that someone else had this problem: Nexus 7 installer gets stuck on 'Erasing Boot Partition"

But what I dont know is, can I disconnect my Nexus 7 and reboot it, or will it not be able to boot into the Android Fastboot recovery screen anymore?

Also is it safe right now to cancel the Ubuntu Touch installer and try again or try the manual steps?

Just want to know whats safe to do and how to fix my problem. :)

Any help would be greatly appreciated.

Also is this the wrong guide? https://wiki.ubuntu.com/Nexus7/Installation

Okay so I want this guide I think: https://wiki.ubuntu.com/Touch/Install

Is it safe to cancel the first one and just start the second one in the current state my device is in? Its still powered on and showing the fastboot android logo / menu?

  • 1
    This guide (wiki.ubuntu.com/Nexus7/Installation) is to install Ubuntu Desktop. This guide (wiki.ubuntu.com/Touch/Install) is to install Ubuntu for Phones/Tablets/whatever it's the current name. – Uri Herrera Feb 27 '13 at 4:13
  • Yes but is it safe for my to reboot my device? e.g. will it still have access to fastboot and the bootloader, I dont know if this failed install of Ubuntu desktop version has touched the bootloader? – Madhava Jay Feb 27 '13 at 5:03
  • Please don't do it just yet, as I'm not sure what else the installer did to your Nexus 7 filesystem. If it didn't erase your bootloader or anything else, then you should be able to reboot. You can even probably flash (or re-flash) a kernel to restore the boot partition. – oaskamay Feb 27 '13 at 22:59

Please don't reboot/power cycle your device just yet, as I'm not sure what else the installer did to your Nexus 7 filesystem.

If it didn't erase or otherwise change your bootloader or anything else, then it should be safe to reboot or power cycle the device. You'll just be stuck in a boot-loop at the Google logo. It's fine, just read on.

Obviously you won't be able to boot into the OS, but you'll be able to boot into the bootloader and do some repairs from there.

Afterwards you can even flash (or re-flash) a kernel to restore the boot partition (from either Fastboot or your installed custom recovery) and boot normally, assuming you have a functional Android ROM flashed into the device, that works in conjunction with the kernel.


I posted on XDA and someone confirmed there that Boot Partition is fine, but bootloader is not.

Turns out that it only crashed erasing the boot partition which is awesome sauce. So everything is fine.

I was using the wrong installer anyway and Ubuntu Touch worked fine.

Just a heads up to anyone else who tries to install Ubuntu Desktop onto there Nexus 7 if it freezes while saying erasing boot partition, just cancel and then reflash what ever you want to get back to normal. fastboot will work fine still.

However, interestingly enough, I disconnected and re-connected it to windows and tried to run flash-all and it failed.

So... if the bootloader was fked at that point but still running in memory I wouldnt have been able to push a new one anyway. I had to reboot the device before I could run flash-all again.... :(

Im sure theres probably a way but yeah, if you find yourself in that situation, dont power down and think carefully before you act.

Glad it was just the partition.

P.S. Ubuntu Touch is lame sauce, I know its an alpha but half the apps are just screenshots... pretty lame guys.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.