I'm trying to upload packages to my PPA for the first time.

I want to use the PPA for customized versions of the OpenStack Compute (nova) project, so I tried to do a test by uploading packages corresponding to the bexar release of this project (lp:nova/bexar), with a new version number and changelog entry. I signed the source packages using my OpenGPG key, which has been uploaded to the ubuntu keyserver:

$ dch -v 2011.1-0ubuntu2-isi1 -D lucid "ISI bexar build #1"
$ dpkg-buildpackage -s -rfakeroot -tc -D -k4C8A14AB

When I tried to upload the files to the repository, it seemed to work (real email obscured):

$ dput ppa:lorinh/ppa nova_2011.2~bzr663-1isi1_source.changes
Checking signature on .changes
gpg: Signature made Fri 11 Feb 2011 03:52:50 PM EST using RSA key ID 4C8A14AB
gpg: Good signature from "Lorin Hochstein <lorin@...>"
Good signature on /home/lorin/packaging/nova_2011.2~bzr663-1isi1_source.changes.
Checking signature on .dsc
gpg: Signature made Fri 11 Feb 2011 03:52:44 PM EST using RSA key ID 4C8A14AB
gpg: Good signature from "Lorin Hochstein <lorin@...>"
Good signature on /home/lorin/packaging/nova_2011.2~bzr663-1isi1.dsc.
Uploading to ppa (via ftp to ppa.launchpad.net):
  Uploading nova_2011.2~bzr663-1isi1.dsc: done.
  Uploading nova_2011.2~bzr663-1isi1.tar.gz: done.      
  Uploading nova_2011.2~bzr663-1isi1_source.changes: done.

However, the packages aren't listed on my PPA page. If I try to upload again, I get the error:

$ dput ppa:lorinh/ppa nova_2011.2~bzr663-1isi1_source.changes 
Package has already been uploaded to ppa on ppa.launchpad.net
Nothing more to do for nova_2011.2~bzr663-1isi1_source.changes

Am I supposed to do something next? How do I track down what wrong? As of this writing, it's been a day and a half since I've done the upload.

Edit: I tried this again, and I received the email notification. I used a slightly different set of flags for dpkg-buildpackage the second itme:

dpkg-buildpackage -S -sa -rfakeroot -tc -D -k4C8A14AB

4 Answers 4


Packages take a while to process. You just need to wait. You will receive an email soon saying that your package was accepted (or rejected) then the packages will build, which will take some time. You should see the build progress on the right of your PPA page.

Once the packages have built (or failed to build), you will be emailed again.

  • 2
    It's been a day and a half since I uploaded the package. What's the typical turnaround time for the accept/reject email notice? Ultimately, I would like to be able to upload new packages every time our branch gets updated, like the main nova project does. But, if it takes several days to upload a new package, then hosting the custom packages on Launchpad is probably not the right solution for us. Feb 13, 2011 at 14:21
  • 2
    It definitely shouldn't take that long. In my experience it takes 2 hours max.
    – dv3500ea
    Feb 13, 2011 at 14:32
  • Does launchpad have your correct email address? Did your spam filter catch it? If it still doesn't show up on the web page then it must have been rejected and it at least tried to send you email explaining why.
    – psusi
    Feb 13, 2011 at 16:50
  • It definitely has my correct email address (I receive other emails from LP). My best guess is that I somehow deleted the email or got spam-filtered. Trying again... Feb 13, 2011 at 19:50

I saw this same behaviour. It was because the signing key I was using had not been added to my profile yet. The dput command doesn't output any error, but the package is silently (no error on the console, or via email) ignored.

So I suggest checking the list of OpenPGP keys in your Launchpad profile.


In my case, I generated a key and signed by build with it, but I neglected to upload my key to my launchpad account. Once I corrected the key error, I had to delete the file <package-name>_source.ppa.upload

From the launchpad docs:

Already uploaded to on ppa.launchpad.net

If after a rejected upload you try to upload the same source package again and dput complains that the source package has already been uploaded, it's because the logfile _source..upload exists. Just remove the .upload file and re-run dput, or invoke dput with the flag -f.


I have recently had the same issue. It took me some time to realize that I have not signed the Code of Conduct.

Someone who's in same scenario, you'll find a link to that in your Launchpad profile page.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .