I've looked everywhere for a fix, but can't seem to find a way to fix this problem, or even anyone else with it.

Whenever I run Kate, I get weird underlining (which breaks easily becoming blurry, etc. if I scroll/resize the window, only redrawing when I minimize and then maximize the window).

Any other user, including root (using kdesudo kate) doesn't have this problem.

I have tried removing Kate config files in my home directory to no avail, although every setting was reset. I have also tried enabling and disabling everything in the settings to.

No other app/user has this problem. The font settings do not have any 'underline' checkbox checked (and I've reset them to no avail even then).

This is on a 3-day old install of Kubuntu 12.10. The problem started the second time I used Kate, and has remained since...

Picture of problem

Thanks for any help!

2 Answers 2


I actually had this same problem not long ago. I have since fixed the problem. Unfortunately, what i did wasn't pretty. I created a new account and then deleted EVERYTHING from my home directory and moved everything from the new account to it. Meaning that I had to reconfigure everything. Of course, shortly after that I found a possible solution to the problem. The problem MAY be caused by a corrupted highlighting definition file. To easily test this try disabling highlighting and see if the issue goes away.

If that worked for you then you'll need to get another copy of your highlighting definitions which aren't borked. You say you can use other accounts just fine so try to just use the ~/.kde/share/apps/katepart folder from a working account in your account. Just delete yours and copy the other over to the same place in you profile.

Hope it helps and let me know.


Having the same issue. A workaround is to change the font size. As soon as it is not set to 10 the lines don't appear anymore. You can do this also with the ctrl key and the mouse wheel.

No real solution, but maybe an acceptable workaround.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .