12

I have been using windows remote desktop from remmina, what i feel so awkward is I don't see the save password button enabled, I need to frequently use my remote connection, and don't like entering username, passwords, etc, everytime...

Help me..

  • did you find a solution? – sepehr Apr 27 '13 at 7:06
  • @sepehr yes i did find, just rename the Quick Connect to any name if your choice, and you are done. – shivshnkr Apr 27 '13 at 12:54
  • 1
    It's a great RDP client. However, it'd be nice if the UI had the following workflow : (Save enabled by default) -> User clicks save -> Error presented that says "Change the name from Quick Connect" -> Name is entered -> Save button works as usual. – blong Oct 21 '15 at 20:15
29

I found out the solution: just rename the Quick Connect appearing in the TextBox to your favorite name, and it is done!

  • it didn't worked for me, my version is 0.9.99.1, which version do you use? – sepehr Apr 28 '13 at 8:14
  • when you are trying to make a connection, you go to Connection->New, there instead of Quick Connect write any name you want, and type in the ip address, username, and password, you will get the save button enabled. – shivshnkr Apr 28 '13 at 12:54
  • I misunderstood your question, my problem is password doesn't save not in edit box of a connection nor when I want to connect to one of defined servers. each time I have to enter password. – sepehr Apr 28 '13 at 17:55
  • The only answer that actually worked.. why is the accepted password so down at the bottom? – Muhammad bin Yusrat May 13 at 1:26
1

Also make sure you own the .remmina folder (and all its contents).

$ ls -l --directory ~/.remmina/

Your user name should appear on the ls record like:

drwx------ 2 username username 4096 Jan 1 12:15 /home/username/.remmina


If root owns this file, You can correct the permissions like:

# chown --reference ~/ --recursive ~/.remmina/

Notes:

  • # Implies "run as root" (eg with sudo), as only root may change ownership of files.
  • --reference ~/ Tells chown to copy the ownership of ~/, which bash expands before the command gets executed, and points to your home folder.
1

Had the same problem, discovered that there is a bug using snap - removed the snap and reinstalled from remmina repository for ubuntu. Also made sure the permissions were set on ~/.remmina. Works fine now. This is on Xubuntu 16.10. Seems that others have also noted that the issue relates to Xubuntu.

sudo snap remove remmina

[Get repo details from remmina site ]

sudo apt install remmina
  • confirmed in 18.10 – Archemar Apr 8 at 13:57
1

create directory ~/.remmina if it doesn't exists and check what you own

0

You need to save your connection, total connection not only your password.

  • well by password, i meant username, password, shared folder, don't u see the last line of my question? – shivshnkr Feb 25 '13 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.