I've already installed Steam, but when I click on the program I get this message

ERROR- You are missing the following 32-bit libraries, and Steam may not run:

I don't know what to install or even do.

  • 2
    We need the complete error message. – Javier Rivera Feb 24 '13 at 20:38
  • 5
    That is the Complete message it doesnt go on after not – Unb3liveblE - PoW Feb 24 '13 at 20:46

No problem. Welcome to Linux and Ubuntu, by the way.

First, if you didn't install Steam from the Ubuntu Software Center, and didn't try, see if you can install it that way, removing Steam from your system beforehand. You may need to run sudo apt-get update in a terminal beforehand (when it prompts you for your password, it's typing even if nothing shows up onscreen). I've also noticed that Steam only shows up in the Software Center when you click "show technical items" at the bottom.

If that doesn't help, see the Known Issues section on the Valve Developer wiki. Follow the instructions for Debian-based distributions:

sudo apt-get install lib32stdc++6

Let me know if these instructions don't make sense.

| improve this answer | |

This seem to happen on every 64 bits OS.

Full bug report here: https://github.com/ValveSoftware/steam-for-linux/issues/321


gksudo gedit /etc/ld.so.conf.d/steam.conf

Add next two lines to file:


Then execute:

sudo ldconfig

Now you should be able to run Steam

solution found here: http://steamcommunity.com/app/221410/discussions/0/864959336441792994/?l=russian

| improve this answer | |
  • 1
    This was my solution in ubuntu 13.10. I don't remember having this problem in ubuntu 12.04. – isaaclw Dec 26 '13 at 18:32
  • 2
    This is the cleanest way to resolve the problem in 13.10. A user shouldn't be creating symbolic links in /usr/lib, as per the current highest voted answer. – XBigTK13X Apr 15 '14 at 14:29
  • This was the solution for me on Ubuntu 14.04 – Tanner Watson Oct 11 '15 at 23:36
  • This is the right way to go - easy and it worked. Nothing else did. – Audie Nov 8 '15 at 7:33
  • 1
    none of these solutions work for me on 14.04 x64. when Steam stars open up terminal and says what dependencies will be installed. but when download ends it says another dependency problems. and then it starts with missing steamui.so error message then quit. – ViBE Dec 12 '15 at 13:47

Here's what I had to do on Intel Sandy Bridge (HD3000 graphics)- for Nvidia/AMD use appropriate source:

sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib

Steam and 3D in vmWare works now.

| improve this answer | |
  • This worked for me (AMD here). What I had to do was install the multiarch 32-bit fglrx package which provides libGL.so, which was named libgl1-fglrx-glx:i386, and then create the symlink to /usr/lib/i386-linux-gnu/fglrx/libGL.so.1. Then it worked perfectly. – Thomas Dec 31 '13 at 6:07
  • Also fixed it for me on Ubuntu 17.10. Thanks! – rene Dec 14 '17 at 21:40

You are propably running an 64bit version of Ubuntu.

Just open the terminal and type:

sudo apt-get install ia32-libs

This way you'll have full compatibility with 32bit applcations, such as Steam, skype and others.

| improve this answer | |
  • 1
    This package isn't available for debian wheezy, or for suacy (13.10). I'm trying to remember when the migration happened for ubuntu... but they migrated from installing 32 bit packages this way. – isaaclw Dec 26 '13 at 18:21

I'm running 14.04 LTS (with elementary OS 0.3.2 Freya 64bit), and this worked perfectly for me:

sudo dpkg --add-architecture i386
sudo add-apt-repository multiverse
sudo apt-get update
sudo apt-get install steam

Also, to note, this was actually a solution for a different (but related) problem.

| improve this answer | |

How to run Steam with ATI 13.04 on Ubuntu 13.04 64bit with kernel 3.8.12:

  1. open terminal

  2. Create startup file in your home directory:

    sudo gedit st3am.sh
  3. put this in file:

    LD_PRELOAD=/usr/lib32/fglrx/libGL.so.1 steam
  4. Save & make executable:

    chmod a+x st3am.sh
  5. Make shortcut and move to desktop or add to your application menu

  6. Have a fun :)

| improve this answer | |

I simply ran using optirun. From a terminal window: optirun steam. Sets steam running on my actual graphics card rather than cpu-onboard intel graphics.

| improve this answer | |

I had a similar problem with nVidia and Steam, using a GeForce 650ti with the 331 drivers. I ended up doing CTRL-ALT-F1 and logging in, then sudo service lightdm stop, telinit 3 (perhaps not needed after the service stop), and sudo sh NVIDIA*.run.

The original 331 drivers were removed, and the installation (this time) went fine, and Steam works.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.