i am trying to get familiar with the Ubuntu package page. My Mac mini is currently offline since i dont get my network to work and i have read on forums how to download and install new Ethernet driver for my mac mini. However when i try to install the drivers the "make" command is not working and i get "error 2" I goggled around for the error and saw a post that said i need the following packages

build-essential, linux-headers, linux-source, etc

I installed Ubuntu 12.10 with a USB stick and it seems almost no packages followed. I went in to [http://packages.ubuntu.com/source/quantal] and found some of them. When i tried to install them i got that dependency is not satisfiable and tried to locate all the dependency files but it ended up that its like 100 of them.

Where can i get a "full" packages that contains all this files i need? i also tried to install keryx but that one also demanded many dependency files so i feel like im running around in circles :) Is there some places for newbees like me to start?

Right now im on a windows PC and i use a USB stick to move all the files around so i guess im asking how to get all the files and dependency i need in 1 go.

  • Is your basic issue that you can't get your network to work? Yet you can access packages.ubuntu.com? Your question is a bit confusing. What is the exact state of affairs? What do you hope to achieve by installing build-essential, linux-headers, linux-source, etc? – user25656 Feb 24 '13 at 12:34
  • Sorry. im using a second computer with windows so i have a USB stick and moving files around :) And as i have read on forums i need to have build-essential, linux-headers, linux-source, etc installed in order to compile the ethernetdriver that i have downloaded from broadcom. When i run command "make" i get error 2 now. – Emil Jansson Feb 24 '13 at 12:49
  • I suggest you edit your question to make it clear that you're trying to compile software. – user25656 Feb 24 '13 at 12:52

There is no need to check package page. If you want to install those packages then you need to open terminal (Ctrl+Alt+T) and install them using apt. For the first time after installation you have to run this command and wait to complete:

sudo apt-get update

After that in order to install any package just simply type:

sudo apt-get install packageNameThatYouWant

edit: In the case of not having a network connection do these steps:

  1. In some other systems that have an internet connection install synaptic package manager.
  2. Select packages that you want to install on your computer with no network connection.
  3. Go to file menu and generate download script for those packages.
  4. Download those packages using some download managers (or any other way that you like)
  5. Copy those files to your machine with no network access, to the folder /var/cache/apt/archives (you must do this as root, open nautilus by sudo nautilus)
  6. Copy /var/cache/apt/pkgcache.bin and /var/cache/apt/srcpkgcache.bin from computer with network access to other cumputer in the same directory
  7. Copy all contents of /etc/apt from machine with network access to the other machine.
  8. Then run sudo apt-get update and then sudo apt-get install packageNameThatYouWant

second edit:There is another way for those who are lazy:

  1. In some other computer install whatever you want.
  2. copy all /var/cache/apt/ and /etc/apt from computer with network to computer without network.
  3. Then run sudo apt-get update and then sudo apt-get install packageNameThatYouWant
| improve this answer | |
  • hi. Thanx for the info but my issue is that i dont have any ethernet working. All guides i have found is based on that internet is working so im alittle bit stuck. I have searched the forum in order to get the ethernet driver installed and on some post they say that i need to install build-essential, linux-headers, linux-source, etc. So when i downloaded them and tried to install alot of dependency was missing. And i would like to have one full package that have all those files and dependencys since its hard for a beginner to really understand them all. – Emil Jansson Feb 24 '13 at 12:45
  • I edited my answer, please edit your question and mention that you don't have a network connection – Mostafa Shahverdy Feb 24 '13 at 13:15
  • I solved this issue by installing this package packages.ubuntu.com/quantal/all/linux-firmware-nonfree/downloadU it made my wireless work so no i only need to figure out how to install my wired eth driver :) – Emil Jansson Feb 24 '13 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.