4

I have most of my music in FLAC on my large storage device, and would like to automatically re-encode it in Ogg Vorbis when copying it to my portable audio player (Sansa Fuze v2). I have set my Fuze to MTP mode and told Banshee to encode to Ogg Vorbis with quality 4 in the Device Properties dialog for the Fuze (I would use MSC mode, but don't have an encoding option in the device properties when I do that). However, when I copy music to the device, either by dragging it from the music library or by syncing a playlist, the full FLAC files are copied rather than transcoded and written as Oggs.

How can I get my Banshee setup re-encoding the audio?

If StackExchange supported bonus points, I'd give bonus points for a solution that only re-encoded music that was already losslessly encoded, but I don't think that's possible.

  • Include a bounty for a solution that only re-encodes lossless files! – djeikyb Feb 16 '11 at 23:53
4

If you can treat your device as a USB Mass Storage device, you might be able to use .is_audio_player to trick Banshee into thinking that your device only supports Ogg Vorbis (not FLAC). If this works, Banshee should automatically transcode your songs to that format every time you sync it.

But it seems like what you really want is the option to override Banshee's transcoding settings for your device. This is being tracked as Bug 576722. Quite a bit of work has already been done, but the person who contributed the original patch hasn't been around for a few months. If anyone wants to help out, I'm sure they'd love some volunteers to polish up the patch and test it.

  • Setting the output_formats variable in .is_audio_player did the trick. – Michael Ekstrand Feb 20 '11 at 1:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.