1

I use Blender a lot (not as much as I used to but still heavily at times). It relies on utilizing the ALT key to move around within a scene. Unity uses ALT to grab windows and allow you to move them with your mouse. Since Unity trumps Blender you can guess which program gets the ALT key. So every now and then I have to go into compiz and change the settings for moving a window from ALT to some other key. It turns out that it's only temporary and after updates or even for no reason sometimes the system will return to using ALT to move windows around. Is there a way to permanently change the key which moves a window?

1

Add the following line to /etc/rc.local to be executed at startup:

dconf write /org/gnome/desktop/wm/preferences/mouse-button-modifier '"<Super>"'

This should change the modifier key to not interfere with Blender's emulate three button mouse (alt key) option.

To remove the modification, delete the line in rc.local and run the command again with <Alt> instead of <Super>.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.