0

When I click a link in a terminal window (like when I'm using trn or mutt) or in the Quassel IRC client, instead of creating a new window or tab in the existing Google Chrome session, it creates a new instance of Chrome. And even if I shut that one down first, it sort of "takes over" so if I shutdown Chrome or log out and log back in, the "Continue where I left off" On Startup option means I only see the one link, instead of all the tabs I had open before.

Is there something I can configure to make those applications use the existing Chrome instance instead of starting a new one?

(This is Kubuntu 12.10)

Update: it appears this behaviour, of starting a new session instead of using the existing one, only happens when it restarts Chrome after I log off and back in. If I start Chrome from the menu button, all works correctly and links clicked in Konsole or Quassel open up in new tabs on existing windows.

1
  • I can confirm the issue on Ubuntu Gnome 14.04 too. – Laurent Jul 8 '14 at 5:26
0

I would try the last google chrome beta version there it works perfectly.

https://www.google.com/intl/eng/chrome/browser/beta.html

if you do in terminal: google-chrome (web-adress) What is the output than?

1
  • If I just type "google-chrome slashdot.org" it opens up a new tab in an existing Chrome window. – Paul Tomblin Feb 24 '13 at 18:12
0

Just guessing here.

Looks as if it konsole runs chrome with the --new-window switch.

not a kde guy, but try editing

~/.kde/share/config/kdeglobals

[General]
BrowserApplication[$e]=!google-chrome

right now it's probably set to google-chrome --new-window

there should be a similar config file specific for konsole. konsolerc. But I think that konsole doesn't have its own browser option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.