I installed Ubuntu 12.10, then installed Nemo. Now I would like to make Nemo the default file manager. I've searched the web for a solution but every time I restart my computer Nautilus come back.

Does anyone know an effective solution?


3 Answers 3


There is a much better way to do this without moving files and setting links. Just open a terminal with CTRL+ALT+T and perform this command:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

Then set up Nemo to handle your desktop:

gsettings set org.gnome.desktop.background show-desktop-icons false
gsettings set org.nemo.desktop show-desktop-icons true

Revert this changes:

gsettings set org.gnome.desktop.background show-desktop-icons true
gsettings set org.nemo.desktop show-desktop-icons false
xdg-mime default nautilus.desktop inode/directory application/x-gnome-saved-search
  • I found that this method doesn't set nemo as the default file manager when, for example, opening an external hard drive from the launcher. I used the other answer and it worked like a charm.
    – duxk.gh
    Oct 24, 2013 at 15:37
  • @duxk.gh I do not use Unity, so can't test that.
    – user5950
    Oct 27, 2013 at 20:16
  • In my case with 12.04 LTS the other answer worked well, this one was still launching nautilus as file manager
    – danijelc
    Nov 9, 2013 at 15:47
  • How would this work for Dolphin? Tried with [this one] but didnt work for me on a 16.04
    – M. Becerra
    Feb 2, 2017 at 19:53

Open your terminal with CTRL+ALT+T and then paste this:

 sudo mv /usr/bin/nautilus /usr/bin/nautilus.back && sudo ln -s /usr/bin/nemo /usr/bin/nautilus

then try again, hope that helps.

Note that this will effectively make Nautilus inaccessible on your system unless you modify shortcuts to point to nautilus.back.

  • 3
    this is a hack, yet very effective! :)
    – ihsan
    Apr 7, 2015 at 5:44
  • 1
    @Raja, This is a great answer. It's the only one that I find that will work. Hopefully eventually setting your default file browser will become a workable feature as with setting the default web browser. With this resolution, if you have an occasion to want to call Nautilus you can call it with nautilus.back. Jun 27, 2015 at 14:05
  • 2
    Thanks for the tip. Could you possibly put a command to reverse these changes for the sake of completion? Thanks!
    – Pablo
    Oct 25, 2015 at 23:55
  • Interesting idea. But this doesn't seem to work in debian cinnamon. It runs nautilus ok from the terminal, but not from within cinnamon via Accessories | Files, nor via Package Manager | Extract | show files, and probably elsewhere too. Just does nothing in these two cases. Sep 1, 2016 at 0:21
  • 1
    Does not work on Ubuntu 18.04 at the moment Apr 28, 2018 at 12:43

Here's what worked for me on 18.04 (source here):

If you have Nemo installed on your system and want to set Nemo as the default file manager, run this command in a terminal:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

To revert this, enter

xdg-mime default nautilus.desktop inode/directory application/x-gnome-saved-search

Nemo (the nemo.desktop app launcher to be exact) should now be the default file manager. To test the result, run this command:

xdg-open $HOME

That command should launch Nemo showing your home directory.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .