5

I was trying to solve internet problems, and seem to have made things worse: Now when I start the computer it gets stuck on "Booting system without full network configuration".

Does anyone know how to make it unstuck?

Alternatively: It got messed up when I changed the contents of /etc/network/interfaces, so presumably would work again if I changed it back. How can I edit this file during boot?

I'm using Ubuntu 12.10.

6

After you see "Booting system without full network configuration" press CtrlAltF1. It should get you to the shell prompt. Use a shell text editor to change /etc/network/interfaces.

For example, with nano text editor it would be

sudo nano /etc/network/interfaces

Press CtrlO and CtrlX to save changes and exit nano after you've done with it. (Pressing CtrlX and then N discards changes) sudo reboot restarts the system.

The default contents of the /etc/network/interfaces file look something like this:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp
  • My file originally did not have the eth0 lines, only the lo lines. Might that be why I'm having trouble connecting to the wireless? – Adina G Feb 24 '13 at 4:20
  • @AdinaG I can't tell for sure. If you're still having any troubles with Ubuntu, maybe it's worth posting another question. – Desmond Hume Feb 24 '13 at 7:53
  • I've same problem my interface file is auto lo iface lo inet loopback auto dsl-provider iface dsl-provider inet ppp pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf provider dsl-provider auto eth0 iface eth0 inet manual how can i solve it ? and my network arrow not show me when type sudo service network-manager restart then show it – Rasel Khan Oct 9 '15 at 4:31
0

I had the same problem after upgrading kernel.

When I executed

ifup eth0 

I got

device not found 

So the problem was not configuration.

My solution: Boot with different kernel.

You can check if you have other kernels in your PC executing:

ls /usr/src/

And you will have entries like this one:

linux-headers-3.13.0-64/

To boot with different kernel, when booting press Shift key and select "Advanced Ubuntu options" and try selecting different kernels until you find the one that works.

After that, remove other kernels.

In my case, I have used version: 3.13.0-61-generic

0

I had exactly the same problem(still new to Ubuntu), I have Ubuntu 14.04 alongside windows 10: Dual boot. I tried most of the solutions posted, but it didn't work, until I rebooted, shut down windows (it was hibernated) when I came back to Ubuntu everything was fine. I hope this helps someone.

-1

I seen this error while booting ubuntu with virtual-box.I followed below line.Next time while booting i didnt see "Booting system without full network configuration" message.

remove /etc/udev/rules.d/70-persistent-net.rules file ,then reboot.

Actually whenever change in MAC address linux add interface in above file.so recent change in mac address not in eth0.

so remove file and reboot ,it automatically create with mac address at eth0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.