1

As advised by this answer, I'm using

gksu deja-dup-preferences

and

gksu "deja-dup --backup"

to backup my data, including files that have root-only permissions on them.

Both of the two ways lead to the same two problems as perceived in comparison to how Deja Dup regularly works.

  1. No report appears after backup is finished. Regular Deja Dup used to bring up a notification, saying that backup is complete, but not in this case.

  2. Deja Dup run with elevated privileges does not memorize either my Amazon S3 secret access key or the encryption password, I have to reenter them over and over again. Running deja-dup --backup in the regular mode always used to apply the passwords from the last successful backup provided that backup destinations match (I had "Remember password" option turned on in all cases, of course). Hence, I'm not certain if automatic backup is going to work if enable it for the root mode Deja Dup and it's gonna take about 2 days to check it.

  • Where is your secret access key? In what directory? – Zlatan Feb 22 '13 at 21:32
  • @ZDroid The Amazon S3 "secret access key" is not a file, it's a string of characters akin to a password. – Desmond Hume Feb 22 '13 at 21:34
  • You need a file to store keys. :P – Zlatan Feb 23 '13 at 9:36
  • @ZDroid Are you sure you know what you are talking about? – Desmond Hume Feb 24 '13 at 19:27
  • 1
    @ZDroid If so, would you like to make an answer from that? – Desmond Hume Feb 25 '13 at 20:01
1
+50

deja-dup uses gnome-keyring1,2 to remember your passwords and keys. So you need to again save your password when running as root, because your earlier setting won't be used in this case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.