22

I have an ACER C7 Chromebook with Ubuntu 12.04 installed. Also I have two apps installed Bluetooth Manager and Bluetooth.

I am trying to connect an MEElectronics AF9-BK Air-Fi Stereo Bluetooth Wireless Headset with Microphone to Ubuntu. I have tried to set up the new device and pair, but the headset is never recognized.

I checked hard and soft setting for Bluetooth and they are on.

I am new to Ubuntu 12.04 and Linux and need specific instructions.

25

Default Ubuntu Bluetooth Pairing

  1. Open the Bluetooth setting by clicking on the Bluetooth symbol on the top panel:
    enter image description here
  2. Choose + in the bottom left corner of the following window:
    enter image description here
  3. Put your Bluetooth device in "Pairing Mode". Check with your manual on how to do this.
    The MEElectronics AF9-BK headset will enter pairing mode by turning the device OFF and then pressing and holding the multifunction button for 7 s until the blue light remains permanently on.
  4. Then Proceed with "Continue" to enable "new device setup" in Ubuntu.
  5. The device should now be recognized:
    enter image description here
  6. Select the new device. In case we use a non-default PIN for pairing we may give "PIN options" but this is usually not needed. Press "Continue" to finish setup.
  7. Go to the "Sound Settings" on the top panel menu:
    enter image description here
  8. Choose your headset as audio output or input device, and give in the "Mode" for Bluetooth service. Note that the microphone will not be available in A2DP mode:
    enter image description here

In case we had used the headset on a different device, or when pairing failed we may have to repeat the pairing procedure. Before we can do so we may have to remove the device first (this is done in step 2. above by pressing -).


Paring with Blueman (here shown for Lubuntu):

  1. Open Bluetooth Manager from Preferences menu.
  2. Put your headset in pairing mode (see 3. above)
  3. Then choose "Search":
    enter image description here
  4. Select the new device and choose the keys symbol for pairing: enter image description here
  5. Enter the PIN code (for headsets this is usually is 0000): enter image description here
  6. Right click on the device to select the Bluetooth service: enter image description here

Also see the following questions:

  • 1
    There is no «Mode» under 14.04 – Ed Villegas Jun 13 '14 at 5:21
  • @EdVillegas: "Pairing mode" is a feature of your device, not of Ubuntu. – Takkat Jun 13 '14 at 6:01
  • Yes, that's what I thought. However, after pairing the device, confirmed both by the system as well as by the headset, there is no such «Pairing mode» in the Sound settings. If I select to «Test sound» of the bluetooth headset, the system uses the laptop speakers. Check screenshot: goo.gl/SsSCAE – Ed Villegas Jun 14 '14 at 15:53
  • 1
    I found the solution. I must install pavucontrol, as you stated as a suggestion here: askubuntu.com/questions/223136/…. Thanks – Ed Villegas Jun 16 '14 at 15:58
  • As @EdVillegas says, "Mode" seems to have been removed, pavucontrol lets you change it. For some reason my speaker wants A2PD though, the other one doesn't work at all. – phunehehe Jan 27 '16 at 16:01
2

You'll need to install these additional packages:

sudo apt-get install pulseaudio pulseaudio-module-bluetooth pavucontrol bluez-firmware

Then follow the procedure in Takkat's answer.

1

I was wrestling with bluetooth headsets off and on for years, with very limited success. I was able to get bluez/blueman working, pair the device, and even transfer audio using a command line program with a manually-entered device name. That did me no good, though. Only one application was able to find and use my headset (ALSA's discovery API doesn't seem to work with BT headsets) and even that app now fails in its most recent version. I have read that PulseAudio makes bluetooth headsets a bit easier, but since Pulse is not viable for me, the situation is still pretty bad.

Then I found this little gadget: Jabra LINK 360 UC USB Adapter

It pairs with a bluetooth headset, but presents itself to the computer as a USB sound device instead of a bluetooth adapter. Every application I have is able to discover and use it because it doesn't require any bluetooth support in the operating system. It completely solved my problem.

Jabra is the only company that I'm certain makes such a thing. They also made one or two earlier models that can be found for less money. I chose the new one mainly because it's so tiny. I have heard that Creative makes something similar; perhaps their BT-D1 or BT-W2. If someone knows of others, please post links.

  • 1
    Thanks ʇsәɹoɈ! Your answer helped me to choose headset for my system. Platronics has such adapter too (named BT300), but it's much more expensive. Also looks like headsets with "UC support" provided with such adapters. Audio device should be less buggy than bluetooth support. – Alex Lokk Apr 15 '16 at 21:57
  • This solved my issues with trying to get a Bluetooth headset working reliably with a Raspberry Pi 3. – Gregir Jan 22 '17 at 5:57
1

Use default Ubuntu Bluetooth Pairing.

Wait for some time and you’ll see that Ubuntu has recognized your Bluetooth speakers as headsets.

Device Search

Once found, Ubuntu will try to setup the device. Have patience. Just wait for a few minutes. If the device setup fails or it asks for a password, try to restart both Ubuntu and speakers, it did work for me. Check also that you don't have another active bluetooth device nearby that interferes with your connection.

Then if the connection succeeds go to the Sound Settings on the top panel menu and enable your bluetooth device.

0

For those using Ubuntu Studio:

  • If not installed, Install blueman (Bluetooth manager) and pulseaudio-module-bluetooth

    sudo apt-get install blueman pulseaudio-module-bluetooth 
    
  • Once you insert USB Bluetooth dongle, the Bluetooth icon appears in the top panel.
  • Turn on the headset, and go to Sound Settings > app/player and choose your headset (by name)
  • Go to the Configuration tab, click the headset name, and choose high fidelity.
0

Now it works for me more or less out of the box for any version 16.04 or above.

When you're connecting or pairing make sure you select Audio Sink then connect your device.

Go to System > Preferences > Hardware > Sound then go to Hardware panel and select your device. You can then test your device.

0

In Ubuntu 18.04 Gnome there is something slightly different. I needed to do in shorten this (RIVAARENA):

In ubuntu 18.04 it is possible to pair and use RIAARENA (in Home or Away switch). Pairing is done/undone by the left part of cradle button ((.)) on the device. Than it is better and sometimes needed to install pulse audio to pair device with player programme - e.q. VLC, Firefox stream, Rhytmbox etc. Pulse Audio -> Configuration. Setup Analog Stereo Duplex, Check if RIVAARENA is on the list.

enter image description here Go to -> Playback Tab. There are all runnig playback applications.

Push button on the left to choose RIVAARENA output for the proper app.

enter image description here Mostly there is delay between sound and video stream. Go to -> Output devices tab to setup proper latency offset (in my case it is maximum 2000ms still little late!).

Documentation which helped me very well:

Intel Q/A https://communities.intel.com/thread/62848. There is very detailed written what to do.

-1

I had this problem. First uninstall then reinstall related packages:

sudo apt remove pulseaudio pulseaudio-module-bluetooth pavucontrol bluez-firmware
sudo apt install pulseaudio pulseaudio-module-bluetooth pavucontrol bluez-firmware

Pair the device, then run

pavucontrol

and configure your Bluetooth device to use whatever mode will work. a2dp worked for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.