8

I have a mounting problem that drives me mad at the moment...

Using the manual mounting command

sudo mount -t cifs //192.168.1.1/shareName /media/shareName -o uid=1000,gid=1000,rw,username='domain/name',password=pw

I am able to mount my network share without any problem. But then, when I include the line

//192.168.1.1/shareName /media/shareName   cifs    uid=1000,gid=1000,rw,username='domain/name',password=pw   0   0

into fstab and execute then the command

sudo mount -a

I receive the error message

mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

When I restart the computer the boot process is as it should be without any errors, but the share isn't mounted.

Does anybody know if this is a bug?! Or do I miss there something?

Thanks for reading this...

PS: I do not have any white spaces in the network share name or any 'weird' characters in the password. Also the cifs-utils are installed. The additional option users in the fstab didn't helped either. Of course I'll use later the credential file when the fstab entry works, at the moment I use the password in fstab just for testing purposes (and it didn't worked neither when I tried the credential file instead)...

PPS: I use Kubuntu 12.10, but I hope this doesn't matter...

2

Mine looks like this - with a credential file as mentioned above, but with some other explicit options.

//192.168.1.2/photos /media/photos cifs credentials=/home/[credentialfile],iocharset=utf8,sec=ntlm,file_mode=0777,dir_mode=0777,uid=[my userid],gid=[my groupid],nobootwait 0 0
1
  • My problem did not exist anymore (new installation), on the new computer I mounted them this way and it worked for me as well, so I accept this answer, to get this thread closed. – Daniel Fischer Apr 20 '17 at 9:07
1

Try specifying your username and domain separately and without the single quotes:

domain=MYDOMAIN,user=myusername
1

Try it with a credential file. I had the same issue. Credential file worked like a charm.

Example for an fstab entry:

//192.168.1.100/music /media/Musik cifs credentials=/home/user/.smbcredentials 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.