I can access the server and non password protected shares by using the following commands: ctrl + l smb://server/share

I can connect to the share using

smbclient //server/share -U 

I can connect using the command line using the following command:

sudo mount -t cifs //server/share -o username=user,password=password,uid=1000,gid=1000,iocharset=utf8,file_mode=0777,dir_mode=0777

How do I connect to this share using Nautilus 3.6.3?

  • would have given more information on what you want and what you did so far
    – Chella
    Feb 21, 2013 at 12:06

2 Answers 2


The new nautilus in 13.04 (raring) no longer shows a place to enter connection credentials. This makes it really hard to connect if you don't know the URI syntax. You can find help for the SMB URI syntax at Wikipedia.

Basically, use one of these URIs:

smb://[<user>@]<host>[:<port>][/[<path>]][?<param1>=<value1>[;<param2>=<value2>]] or
smb://[<user>@]<workgroup>[:<port>][/] or

The user name can contain spaces explicitly and doesn't require encoding. Myself, I used the following:

smb://My User@WINDOWSHOST/Share

You then are prompted for the credentials. I'm not sure if the share name can have a space since my shares don't have them, so I haven't tested it.

Once you access the share, you can right-click on it in the left panel and Bookmark it. This will make it remap when you log off and back in so you don't have to keep using the Connect to Server method all the time.

  • Last example worked for me. When I try to connect to a Windows Share (from Ubuntu 14.04 to a PC running Windows) if the connection is refused Nautilus shows the credentials prompt dialog, the problem is when the destination Windows PC allows read only access to guest users. This is annoying because Nautilus connect with read only permissions and you are never given the chance to gain write access. That URL worked. Now I have write access as I can enter the password, thank you. Use "smb://user@host/resource" and Nautilus will show the dialog. Oct 4, 2015 at 19:28
  • The problem, that data transfer by cifs mount is about 10 times faster than mount with gvfs. By gvfs mount we got the password prompt, by cifs mount we don't. :S Hopefully this will be fixed soon.
    – inf3rno
    Feb 28, 2016 at 7:58

Based on my nautilus (3.4.2), in unity menu, you choose file, connect to server, then server details (the ip of the shared directory), type (windows share), and then you state share, folder and user details (domain, user, password). My install runs with cifs-utils installed (sudo apt-get install cifs-utils). You can also mount this share during start-up by adding in /etc/fstab:

//192.168.X.Y/shareddirectory /home/user/sharename cifs auto,iocharset=utf8,uid=1000,gid=1000,user=username%password 0 0

  • I know I can mount the directory from /etc/fstab, but that mounts it permanently. I only need to temporarily access a share. It used to be easy to do from Nautilus as their was an option to add a username and password. You can no longer add the username or password. I need to find out how to do this. Feb 21, 2013 at 11:57
  • if you try to connect to server from nautilus via file menu?
    – bob
    Feb 21, 2013 at 11:59
  • The message received is: "Unhandled error message: Failed to mount Windows share" Feb 21, 2013 at 12:02
  • Sorry, I do not know. The only way I see is each time you want to mount it, you run mount.cifs ... in terminal and then you will see it in natilus.
    – bob
    Feb 21, 2013 at 12:11
  • or alternatively in fstab to use noauto instead of auto
    – bob
    Feb 21, 2013 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.