Hello I searched for this query(mounting all partitions on system startup) and found answer near to it. I added this command to startup applications "/usr/bin/udisks --mount /dev/disk/by-uuid/A2E6A54AE6A52011" and other three partitions separately. When i close and open startup applications it wont save all three partitions. It is saving only the last command added. Is there any way i can mount all partitions at system startup ? And the above procedure i followed is also opening that system partition resulting to delay in boot. If possible tell how to just mount all partitions but not to open all. But i want all partitions to be mount automatically. Please help me.

Image of what i edited fstab

The last three lines are the lines I added. According to your first suggestion.

According to your first suggestion

According to your second suggestion.

According to your second suggestion

This is the result of both edits.

Drives disappeared

Ok... Let me be more specific...The image below shows all the partitions of my internal hard disk. 1. I Just want to mount the partitions labeled (a) Sumana(Backups), (b) Movies,Doc's and Songs (c) Personal all partitions

This is the output of df -h

output of df -h

This is the output of cat /etc/fstab output of cat...

And this is the uuid of all partitions


Now i want to mount sda3, sda5 and sda7 if possible even windows partition sda2.

Sorry if I'm bothering you brother. I had Unix as subject and now I'm interested in learning commands and customizing like this. And i wanted to mount. Hope I've uploaded all outputs you want.

  • I am confused: What is your precise problem? What exactly are you trying to mount automatically? Is it a disk? First you need to make sure that your boot and root partitions are mounted (and stay mounted). To let us help you, post the output of either 'mount' or 'df -h' in your answer above. Then, post the output of 'cat /etc/fstab'. What you describe you are doing in your comment sounds dangerous. Please don't do more, before you haven't figured things out. You can also use 'Disk Utility' to see what disks you have and where they are mounted.
    – DrSAR
    Commented Feb 22, 2013 at 18:37
  • Also, you can check your work without having to reboot all the time. After adding something to fstab, you should be able to say 'mount /mnt/sda5. Make sure that your moint points exist before you mount. Also, do not mount several devices in the same mount point.
    – DrSAR
    Commented Feb 22, 2013 at 18:41

2 Answers 2


You should add the partitions in question to your /etc/fstab. The following line will automatically mount /dev/hda2 at boot (that's hidden in the flag default).

/dev/hda2   /   ext2    defaults    1 1

If you don't want to mount, you would issue noauto amongst your options. In your question you appear to be using uuids to address your partitions. You should probably write something like:

UUID=A2E6A54AE6A52011   /mnt/somedisk  auto   defaults 0 0

Using man fstab you can learn the specifics of the file's syntax.

Update after you posted your fstab and so on.

You really did screw up the mounting. I am surprised you can boot with four devices mounted into the same mount point /. Presumably, it mounts the first (your all important root partiation /dev/sda8) and then fails with mount point not empty when it tries the others (or some other error dependent on the type of file systems involved)

At any rate, you need to learn about fstab. Have a look at some of the first google hits for understanding fstab.

So here is what you should do:

First create the mountpoints:

sudo mkdir /mnt/sda2 /mnt/sda3 /mnt/sda5 /mnt/sda7

If you wish you can be more creative with the names. You can also put them somewhere other than /mnt. Your choice.

Next edit your /etc/fstab and put in lines for each of them

/dev/sda2 /mnt/sda2 auto defaults 0 0
/dev/sda3 /mnt/sda3 auto defaults 0 0 
/dev/sda5 /mnt/sda5 auto defaults 0 0 
/dev/sda7 /mnt/sda7 auto defaults 0 0 

I think you had a spare whitespace between the slash and the mnt/sda. These things matter since you broke the mount point into two.

Then, do not reboot. You should be able to test it saying:

sudo mount /mnt/sda2 # and so on for the other partitions

If that works, on next boot they should all come up. If you wish you can replace /dev/sda2 and so on with their respective UUID

footnote instead of screenshots, simple text would have made it possible for me to copy and paste your fstab. As it is, it's pretty but uses more bandwidth and conveys less usable information.

  • Oh my god!! I'm new to Ubuntu. You have to help me please @DrSAR. At first I added /dev/sda3 / ext4 defaults 1 1, /dev/sda5 / ext4 defaults 1 1 and /dev/sda7 / ext4 defaults 1 1 line by line and saved it. But at next reboot instead of mounting all these disks were disappeared. I also used second method. I deleted above lines and add these lines UUID=E63A13DB3A13A797 /mnt/sda5 auto defaults 0 0, UUID=A2E.... /mnt/sda7 auto defaults 0 0 and UUID=A8C66..... /mnt/sda3 auto defaults 0 0. But no luck. Its not showing in computer and not mounting also. Please help me.
    – learner
    Commented Feb 21, 2013 at 16:15
  • Please tell me what i exactly need to add @DrSAR. Thank you for your immediate response.
    – learner
    Commented Feb 21, 2013 at 16:19
  • You mounted three different devices all in /. This is most definitely not what you want. You need to (1) Stop now and (2) respond to my comments above and (3) learn about mounting and /etc/fstab in particular. If you don't, you will screw up your system royally. Promise.
    – DrSAR
    Commented Feb 22, 2013 at 18:42
  • Hello @Aditya.... I want little more help from you. As i told i used the above suggested lines while editing fstab file. But instead of mounting all drives mentioned in fstab is disappearing from computer folder. I just want to know whether is it syntactical error. If I want to upload image of what i edited I'll do.I already tried to upload image as instructions given but it didn't upload anyway I'll try again. But I'm waiting for your answer. I want to mount all partitions. Thank you for your quick reply last time.
    – learner
    Commented Feb 24, 2013 at 3:00
  • Wow!! Thank you bro... It really worked. But as u said I mounted in different location. I mounted at /media/padmahasa... Now auto mounted drives are not opening as it was happening when i used startup applications. So my ubuntu is booting in a normal speed. I had tried so much for this before. Thank you very much for answering all my questions brother...
    – learner
    Commented Feb 25, 2013 at 15:56

You can easily do it using "Storage Device Manager". To install Storage Device Manager run

sudo apt-get install pysdm

After the installation run the "Storage Device Manager". From the left hand side panel choose the partition you want to be mounted on startup. Then click on “Assistant” on the right side. Now check the “The file system is mounted at boot time” and uncheck the “Mount file system in read-only mode”. When done click the “OK” button then hit “Apply”. Now Restart to see the effects.

  • Hi @MARUF SARKER. I gave the command to install pysdm but it is giving E: Unable to locate package pysdm.
    – learner
    Commented Feb 24, 2013 at 16:11
  • @learner: That means your sources are probably not correct or you are not connected to the internet.
    – DrSAR
    Commented Feb 24, 2013 at 19:22
  • 1
    @learner : In case of Ubuntu 12.10 pysdm is removed from the Ubuntu repositories. But you can download it from 12.04, the link is here ftp.ubuntu.com/ubuntu/pool/universe/p/pysdm/… . After download, install it using sudo dpkg -i pysdm_0.4.1-0ubuntu3_all.deb
    – MARUF
    Commented Feb 26, 2013 at 3:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .