I have tried clementine, rythembox, banshee, and gtkpod. Nothing works, even though my ipod says synchronizing and in the player it says the music is on the ipod. When i disconnect nothing has been copied to the ipod.

Ubuntu 12.04 Ipod 5th gen nano (video camera)

Please help, have no more hair to pull out of my head.

  • 2
    This is... well... apple all the way. I'm afraid there is no solution to this. They change their protocols on purpose so that you can't access them through 3rd parties. See the first paragraph here. But let's be optimistic and hope that one of the gurus here has a workaround. The link suggests using Gigolo, but that's only for mounting, and you can clearly do that. It looks like a dead end. – phipsalabim Feb 20 '13 at 23:13

I've just tried this today on 12.04, with Banshee and an Ipod Nano 5th Gen (black).

1) Restored it with Itunes in Windows and named it.

2) Mounted under Ubuntu

3) run in a terminal the following command: sudo lsusb -v | grep -i iSerial

4) Copied the 16 digit GUID (mine began with 000A)

5) Browsed to http://ihash.marcansoft.com/

6) Entered the 16 digit GUID and downloaded the resultant file HashInfo to the 'iPod_Control/Device' directory on the iPod.

7) Opened Banshee and copied music / podcasts to the nano.


For what it's worth, I've been using GoodReader (http://www.goodreader.net/goodreader.html) to sync music to my iPod Touch running iOS5.

Pro: GoodReader syncs over wifi as a WebDAV mountpoint. This means that you can just copy music files to it like any other folder.

Con: It will only play the files within the folder structure that you supply. Unfortunately, this means that it's hard to make playlists.

This is definitely not a perfect solution, but it's the best workaround that I've found for now.

I wonder whether there are other iOS apps that allow syncing like GoodReader, but also can re-organize files as a fully-fledged music player.

  • The original question specifies an Ipod Nano, which doesn't run iOS or have wifi. – Mark Williams Mar 17 '13 at 22:29
  • Hmm...My mistake; I didn't see that note when I posted. Sorry about that, @ Brownbuntu! – J L Mar 17 '13 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.