8

Each time I switch to manual configuration, of wired connection in Ubuntu 12.10, the save button gets grayed out. As soon as I start setting it in Manually, it gets grayed out.Please help !

One more thing, system continuously displays a message at the top-right corner of the screen, saying:

Wired Network- Not connected

  • I've had the apply button not un-grey when the netmask put the gateway on a different subnet to the chosen IP. Really frustrating that there's zero error reporting for this. – jozxyqk Aug 7 '17 at 23:22
  • I needed to check the "No CA certificate is required" on the security tab. – Paused until further notice. Jan 17 '19 at 18:42
6

Found the solution: It's a GUI problem: When adding static IP you may end up with an 'invisible' blank line in the list of IP addresses which prevents saving settings - just click below your IP address and delete the blank entry.

| improve this answer | |
  • this works, but for some weird reason even after saving and exiting out of the configuration I had to reboot for the changes to take effect – Michael Oct 14 '18 at 21:20
  • Doesn't work for me. No blank entry. – Calmarius Apr 8 at 15:52
4

The button is greyed-out if there a missing or wrong information filled in the fields. Make sure you put it in like this:

  • IP Address: 192.168.1.20
  • Netmask: 24
  • Gateway: 192.168.1.1
  • DNS: 192.168.1.1 (not required for having a save-button)

Otherwhise please give us a Screenshot.

| improve this answer | |
  • I put the same info and still the button is greyed out. Ubuntu network GUI is broken. – dev_nut Mar 10 '18 at 23:21
1

I faced the same problem, the way around is to do it from command line. Go to the file /etc/network/interfaces and change it to

auto eth0
    iface eth0 inet static
    address xx.xx.xx.xx
    netmask xx.xx.xx.xx
    gateway xx.xx.xx.xx
    dns-nameservers xx.xx.xx.xx
    dns-search xx

where you have to fill the xx given by your ISP.

Then from commandline do

sudo ifup eth0
| improve this answer | |
1

In my experience this happens when information is missing. The so far mentioned answers are correct. I would also like to add additional scenario - wireless. In my case I had a 802.1x. I couldn't save the password I have entered in my setting post-creation of the profile itself. I forgot to add the certificate. After I did that it all worked fine and the Save button was enabled again. In this case I could have also chosen the option not to require a certificate but either way one of both had to be entered as information.

In short - always check if you have entered all the information that is required from you for the network profile you are creating.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.