2

I just installed Ubuntu 12.10 on a new Intense PC, which uses a single 3.5mm audio jack for both digital (S/PDIF) and analog output. I'm trying to get the analog output working, but in the Ubuntu sound preferences, the only option available (under "play sound through") is "Digital Output (S/PDIF), Built-in audio" and no sound comes through the analog speakers I have plugged into the output jack. I'm not sure what to do to get analog output to show up in the list of output device choices.

Any ideas?

Some potentially relevant hardware information:

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thanks!

1 Answer 1

0

Maybe you have to modify the archive /etc/modprobe.d/alsa-base.conf and add a line like this:

options snd-hda-intel model=XXX

where XXX depends on your computer model.

xxx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.