62

When opening a folder, by default it always shows hidden files. I can uncheck the view option and they disappear but reappear on the next opening with the hidden files option re-checked. Have I inadvertently changed an option or is this a bug? No-one else seems to have encountered this.

  • 1
    Go into your file manager's preferences and untick "Always show hidden files" or something like that. – user25656 Feb 20 '13 at 8:46
107

Assuming you are using Nautilus (the standard file manager in Ubuntu), read the help files on Nautilus views. To change the default option, you can do the following:

In any file manager window, click Edit ▸ Preferences and select the Views tab.

In that tab you can unselect show hidden and backup files. By default,

The file manager does not display hidden files or folders.

You can also toggle showing/hiding hidden files by using CTRL+h.

  • 8
    Of course, easy as that - many thanks, I wonder why it changed from default unprompted though. – Wittypicker Feb 22 '13 at 8:09
  • You're welcome. Let us know if you find out what changed the default. Welcome to Ask Ubuntu. – don.joey Feb 22 '13 at 8:15
  • unfortunately the link is dead – anion Jan 23 at 21:37
  • @anion updated. – don.joey Jan 24 at 8:36
  • good one, I accidentally revealed my folders while doing ctr+h in SublimeText and was surprised to see so many extra folders in my home dir, I was just about to purge them when I saw they are not shortcuts or garbage LOL – Vitaliy Terziev Feb 14 at 17:49
31

I'm using ubuntu 15.04. Recently I upgraded form terminal using the cmd "sudo apt-get upgrade". After this Nautilus was showing all the hidden folders by default. However, after searching a while in internet I ended here. Maybe the solution I post here has already been posted in some forum, but here is how I solved the problem in Nautilus.


  1. Install the "dconf editor" using the command:

    sudo apt-get install dconf-tools
    
  2. open dconf editor using the command:

    dconf-editor
    
  3. Browse to org > gtk > settings > file-chooser

  4. Uncheck the "hidden file" key appearing in right side.

That's all. Enjoy!

The key from org > gnome > nautilus > preferences : show-hidden-files is ignored as it is deprecated.

  • 1
    This worked for me. For whatever reason my version of nautilus doesn't have an "edit" menu option and looking at other stack overflow answers suggesting I change org > gnome > nautilus > preferences doesn't work (which itself had "show hidden by default" off anyway). Not sure why this happens since I didn't change or mess with anything when it decided to default to showing hidden files. – Ram Nov 19 '15 at 0:47
  • Here are the bug report and solution mentioned. – mxdsp Dec 13 '15 at 2:50
  • 6
    One liner : gsettings set org.gtk.Settings.FileChooser show-hidden false – mxdsp Dec 13 '15 at 4:46
  • @mxdsp You rock. Your oneliner is great. – Luis Masuelli Jan 17 '16 at 18:55
  • Good workaround for a bug recently.. using nautilus, you cant make the hidden files to not show by default.. no matter what. – ashishsony Jan 27 '16 at 23:04
5

Here are the steps I took to remedy this.

  • Open File Explorer.
  • Goto Preferences under Edit menu
  • Uncheck Show hidden and backup files if checked
  • Close and enjoy, see below:

    image

3

Another way to fix it: open gedit, type something and click on save. When the file chooser window opens, press Ctrl+h to show/hide hidden folders. This changes the settings to the way they're supposed to be.

  • Ctrl +h is just a shortcut from Nautilus. Gedit just opens a Nautilus session in the background, but this shortcut also works in Nautilus without entering Gedit. – Requist Jan 9 '16 at 10:45
1

As others have said, the default behaviour can be changed after opening file manager and going to Edit->Preferences->Views and unchecking Show hidden and backup files.

Using Ctrl+H only temporarily toggles hidden files, and when a new window is opened the default view comes again.

Now I am going to say that why suddenly the default behaviour got changed even when you don't remember changing it.

It is because when the file manager is opened externally, (like choosing file to upload in a browser, etc), and we press Ctrl+H, the toggle is not temporary, it is permanent.

I found this issue/feature in Ubuntu 16.04.

0

Ubuntu GNOME 16.04 LTS with Gnome Files 3.14.3

To make it clear: I don't have the Unity desktop. If you have Unity or other desktop besides Gnome, this answer may not be of use to you. Second, I have done some mods so my panel may look different and may be in a different location. However the concept should be the same if you are using Gnome.

Gnome panel with Gedit closed

This image shows that you cannot access the Files Preferences menu when Files is closed. So whether you have Files docked in the panel or not does not matter. You need to open Files before you can start.

Files Top Menu

This is my menu in the Files app. Note I don't have any menu like "Edit->Preferences" as others have shown elsewhere.

RightClickFilesIcon

When Files is open you can right (outside) click its icon in the panel to open "Preferences".

Files Preferences Window

Now when I go to the "Views" tab I can see "Show hidden and backup files". At this point my answer should be the same as shown elsewhere. It's just a matter of understanding that not everyone has the same desktop or Ubuntu version.

  • You want me to answer the question: Have I inadvertently changed an option or is this a bug? – Sammy Joe Jan 9 '18 at 22:57
  • One answer was "Go into your file manager's preferences and untick "Always show hidden files" or something like that. – user25656". Not helpful if you can't find file manager's preferences. I showed how to do that. Another answer: "In any file manager window, click Edit ▸ Preferences and select the Views tab." Worthless answer for those who do not have "Edit" in any file manager window, since it is actually embedded in the icon. Basically I had the exact problem with Files app showing hidden files. I did not find the answer here, so when I finally found it on my own I decided to post it. – Sammy Joe Jan 9 '18 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.