I'm running a fresh install of Kubuntu 12.10 with KDE 4.10 installed from the Backports PPA. This is my first time using KDE, so I'm still learning where to find everything. I've got KDE's Power Management settings set to my liking, so that when I close my laptop lid, the screen turns off but the computer does not go into suspend mode. This works fine when I'm logged in.

However, when I'm logged out (i.e., looking at the LightDM login screen), if I close my laptop lid, the computer does go into suspend mode. How can I turn this off, so that the computer does not suspend at the login screen when the lid is closed?

I've searched on several sites for an answer. However, almost every related question that I found was about turning off suspend when a user is logged in; this problem is a bit different. I did find Stop laptop from suspending when closing lid in lightdm, which does gives a CLI answer to this problem. I'm wondering, though, whether there is a GUI setting to toggle this. Is this a bug, or is there a setting that I haven't found yet?

I'll also be happy with answers that better explain what the answer to the linked question is doing.

Thank you very much!


If your system has moved to systemd, specifically the logind service, settings for the logind service will control the system's behavior when the lid closes.

Specifically, look for the logind.conf file (probably at /etc/systemd/logind.conf), and edit it to set the HandleLidSwitch setting (to ignore).


After this, make sure to restart the logind service, either via a reboot or systemctl restart systemd-logind.service.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.