I just installed my first Ubuntu desktop as a dual boot with Windows 7. I had to install without internet access because my wireless wouldn't connect, it's not possible to use a wired connection.

My USB WiFi adapter was bought off Ebay recently and says compatible with Linux. For it to work with Win 7, I had to install the driver provided in the Ebay listing, it's a link to download a zip file.

I tried downloading the zip and copying it to Ubuntu but when I try to run Setup.exe I keep getting "An error occurred while loading the archive. Meanwhile I keep getting asked for my wireless password (which isn't working). The Ebay listing with the driver is item number 261161990604.

Can anyone help get me online? Thanks a lot!

Using Ubuntu 12.10

lshw -C network shows:

WARNING: you should run this program as super-user.
       description: Wireless interface
       physical id: 2
       bus info: usb@1:5
       logical name: wlan0
       serial: 00:0f:13:05:1c:1d
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192cu driverversion=3.5.0-17-generic firmware=N/A multicast=yes wireless=IEEE 802.11bgn
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

lsusb shows:

Bus 001 Device 005: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
  • 2
    Hi and Welcome to Ubuntu. The windows driver will not work on Ubuntu like that. Chances are though, your wifi card can be detected by Ubuntu anyway. But you'll have to give us some more info. First tell us what release of ubuntu are you on? Is it 12.10? Second: to get some idea of what wireless card you are using, can you type the folowing 2 commands in a terminal window and copy the results back in your question (by using the edit button): lshw -C network and lspci -nn gd luck – matv1 Feb 19 '13 at 23:54
  • 1
    I think we also want to see lsusb since it's a USB device. If you are being asked for your wireless password, it is likely the driver is already installed and we just need to tweak it a bit. – chili555 Feb 20 '13 at 0:02
  • 1
    yeh sorry i missed the usb adapter part :) we need lsusb as well – matv1 Feb 20 '13 at 0:08

Try changing your encryption to WPA2, see Network Manager (nm-applet). It might work.

| improve this answer | |
  • I can go into it but it's already on WPA & WPA2 Personal. Maybe I should say it keeps adding multiple versions of my network in the Network Connections list, with 1,2,3 beside the name. Unless I'm somehow causing that. – Amy Feb 20 '13 at 1:13
  • can you post the result of rfkill list – matv1 Feb 20 '13 at 1:29
  • rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no – Amy Feb 20 '13 at 11:07
  • I would try changing the router to WPA2 only and not mixed mode WPA and WPA2. Do you have a temporary wired ethernet connection if we want to update the driver? – chili555 Feb 21 '13 at 14:12

Well you have established that:

  • the usb device is recognised by your Ubuntu

  • a driver was found and is loaded

  • the network device is not blocked on a hard- or software level

And the fact that you are being asked for a password shows that your wireless access point (router) is seeing your usb-network device and is able to assign an ip adress to it.

So the fact that you're not getting an internet connection can only mean that the access to your router is not correctly configured.

Click your network manager menu-icon (top right).

First: you should check if the networkname you want to acces is listed in the list of available networks. Is it? (remember if there are many available wifi signals, you may need to hit the 'more networks' label)

If it is: Be sure you have a checkmark with both 'enable Networking' and 'enable Wireless'

Then: Go to 'Edit connections' and then the Wireless tab. Delete all the entries of your desired network except one. Click that one and hit 'Edit'. Go to the Wireless tab. checkbox the 'Connect automatically'. SSID should be the name of your network. Mode depends on how the router config but should typically be 'Infrastructure'. MAC adress should be filled already, MTU 'automatic'

Next tab (IPv4 Settings) again depends on the router config, but typically should be 'Automatic'

Next tab (IPv6 Settings) again depends on the router config, but typically should be 'Automatic' or 'Ignore'

Last Tab (Security): like Catalesia suggested in the other answer, you have to be sure of the security-method of your router (WEP, WPA etc), and be sure of the password.

Hit save. See if you have a working internet connection now

| improve this answer | |
  • Please let us know if that worked and if not, at what point it fails – matv1 Feb 21 '13 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.