I am using the unity interface and i usally work with maximized windows. However lately i noticed that i cannot resize windows. I can get them maximized and to normal state.

When in normal state i move the mouse to the border and the cursor changes to the "resize cursor" but then nothing happens when trying to drag the border.

Starting a guest session i can see that resizing works so it has something to do with my profile.

Lately i used gsettings to disable overlay scrollbars but even resetting to default values does not solve the problem and i am not pretty sure the problem started after using gsettings.

Any solution that does not require resetting everyting?

As an extreme measure what files should i delete to reset the profile settings?



first let's reset compiz and gsettings to default. Press Ctrl-Alt-t. In the terminal run:

sudo add-apt-repository ppa:amith/ubuntutools
sudo apt-get update
sudo apt-get install unity-reset



For tweaking ubuntu install: ... ubuntu-tweak

sudo add-apt-repository ppa:tualatrix/ppa 
sudo apt-get update
sudo apt-get install ubuntu-tweak

In the dash search for "ubuntu tweak"

Once open, click Tweaks tab, then Miscellaneous, then toggle Overlay scrollbars off

enter image description here

  • Running unity-reset solved the problem, however it crashed the UI and i am not really sure it did finish the job it was doing. The said software seems to be a bit immature. – marcopar Feb 19 '13 at 16:53
  • it's not in the official repository. So yes, it's not something you should run regularly. Is the UI ok after re-login? Did Ubuntu-Tweak crash on you or was it just the unity-rest command? – phipsalabim Feb 19 '13 at 17:40
  • unity-reset freezed and then then unity (or something related) crashed. i had to give a lightdm restart to recover. the gui is ok now anyway. – marcopar Feb 19 '13 at 20:28
  • Great to find this. Just tried it and it works great with my unity-2d setup (compiz crashes under xrdp). – Reinier Post Sep 4 '13 at 9:29

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.