0

primarly asking for directions here,

since I seem to be able to find either outdated howtos, solutions that send stereo audio to more channels (and that's not "upmix to surround"), or plain 5.1 setups.

hardware is a z68 hdmi out, connected to a denon 1301 HT; in ubuntu Sound panel, I'm using 5.1 hdmi digital out.

the Denon is able - and already set to - fall back to ProLogic IIx upmix that I'd be more than happy to use when I'm playing stereo audio, but under ubuntu (differently from what happens under windows) only multichannel audio reaches the amplifier, forfeiting Prologic.

btw, For some reason, trying to get direct forwarding of AC3/dtc audio to the HT only produces noise (again, differently from what happens under winslow), thus hampering any hope to use dts master audio etc. and making impossible to use a workaround like "upmix stereo in software, play advanced multichannel thru hardware"; but I digress.

back to what is happening now: multichannel-only audio from pulse, than.

what I'd like to do is:

  • having some surround upmix of sorts when playing stereo audio
  • having multichannel audio "right" when i'm playing multichannel.
  • not having to manually switch configuration files when moving between upmixed-stereo to multichannel and vice-versa.

it's not clear to me if I can obtain this setting using Pulse, or if i have to resort to alsa (and how?)

for now, I'm using smplayer2 with an audio filter string of

surround=15,sub=100:5,center=4

where the first number is the delay between the front and the rear channels

but i't it doesn't look like the RIGHT thing to do, to me, because: - it is a pain to play multichannel media (i have to manually remove/restore the filter options, otherwise the audio is horribly crippled down) - it only works in mplayer2, and I would like to have some consistency across ALL the media player software....

I'm REALLY lost here. can you point to me to some consistent approach?

what do you suggest?

thanks a lot in advance.

1

The file ~/.mplayer/config can be used to set extension or program based settings: add

[extension.mp3]
profile-desc="for .mp3 files"
af=surround=15,center=4,channels=6,sub=100:5

this way only *mp3 files will be mixed up to 6 channels

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.