I'm on Ubuntu 12.04, and trying to connect my Samsung galaxy Gio (Model # GT-S5660M) with Android 2.3.4 (GINGERBREAD_MR1). When I plug my phone in,via USB, it will charge, however Ubuntu will not recognize it in any other way. I tried the MTP programs in the software center however they both turned out to be of no use (neither detected the phone).

So my question is, How can I make it so I can, at least, transfer audio and videos to the micro SD in my phone with out removing it and using an adapter?

  • I have same issue with my phone. But I discovered that it was one particular port that wouldn't mount the phone as memory device (charge it though). However, it worked well with another port on my laptop. I haven't been able to isolate the exact issue though.
    – jitendra
    Commented Feb 18, 2013 at 20:00
  • I was facing the same issue , with my xperia neo and I just booted into windows explored sdcard after connecting and then restart and boot into Ubuntu ,and it will work fine for sure.
    – Sukupa91
    Commented Nov 24, 2013 at 0:21

4 Answers 4


I am using Android 4.0.4 with Sony experia.This solution work out for me.

Open a terminal in ubuntu 12.04


sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update

then open software update and install available updates. Then restart the system and after restart your Android phone internal data storage will be listed in the devices automatically.

You can find out detailed information on this link


On stock Ubuntu 12.04, MTP support has many issues with Android phones. There's a PPA available, that brings better MTP support to 12.04.

  • Thanks for taking the time to reply. I didn't have high expectations for an answer but I thought I should try anyway. Maby someday I'll make it work.
    – Nemo
    Commented Feb 24, 2013 at 15:11

I know the topic is a bit old but I just want to add couple words from my own experience. I am running Xubuntu 12.04 and Thunar as default file manager on it. I had Samsung GT-5500 on Android 2.2 and there was no troubles with the files transfer at all. Couple days ago I changed it to Alcatel One Touch 4030x and Android 4.1.1 Jelly Bean, and when I connected it to my laptop it did not come up.

When I checked lsusb I found it as:

Bus 002 Device 009: ID 1bbb:0167 T & A Mobile Phones

The funny think was a fact, I could add this USB device to my Windows 7 virtual machine as external USB and Windows recognised it, and installed required drivers automatically.

Links and syntax above from shailendra are very useful, but in my example it did not resolved this problem completely. What I did was to install Nautilus file manager and change it to the default system file manager. Now, when I connect my mobile it come up every time and I can see it as:

Devices -> MT65xx Android Phone with path mtp://[usb:002,009]/ (screenshot here)

but there is some other issue as well. I have to have my screen unlocked when I do that. Otherwise it will come up, but when I click on device it does not show any SD cards. It's empty. I hope my tips will helps somebody else. Good luck


With Ubuntu 12.04 I could not connect to my vanilla Android 4.1.1 tablet as a USB storage device, to copy files between my computer and the tablet. I followed the advice here without success. Running lsusb in the computer's terminal showed that the tablet was connected as a device (and the USB cable was probably OK), but gMPT reported 'unable to open raw device'.

Maybe what I wanted to do is not what you want to do, or your Adroid device may be different than mine, but here is how I got Ubuntu 12.04 to treat my tablet as a USB drive, copying files (both ways), deleting files, and managing directories, etc. in the tablet.

Step 1. remove mtp-tools mtpfs gmtp from Ubuntu (something like sudo apt-get remove mtp-tools mtpfs gmtp); when this was installed Step 2 did not make any difference.

Step 2. in the Android tablet (not Ubuntu) go to Settings then to Developer Options and turn ON 'USB debugging' so a check mark is shown next to this option - at least on my tablet.

Then I plugged the USB cable from the tablet into my computer. The tablet's memories, internal and installed micro flash drive, were accessible on the computer's desktop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .