3

I have installed the Ubuntu phone SDK on a VirtualBox VM running Ubuntu Precise (12.04.2 LTS) as the guest OS.
The "guest extensions" have been installed.
The guest OS kernel is 32 bit 3.2.0-37 without PAE.

I followed the installation instructions for the SDK on http://developer.ubuntu.com, and the installation seemed to go smoothly.
However, when I attempt to run the demo "Currency Converter" app, qmlscene reports many errors with the form:

OpenGL Warning: XGetVisualInfo returned 0 visuals for 0x8db7f98

ultimately followed by the message:

Unrecognized OpenGL version

A black box pops up, but nothing is drawn within it. Does anyone know what might be causing this problem?

2

simply disable the 3d graphic accelaration in the virtualbox vm settings and it will work. Put both off 3d and 2d accelaration

| improve this answer | |
1

I had been using a pretty old laptop to run virtualbox. I installed virtualbox on a newer Macbook Pro, and re-installed Ubuntu + Phone SDK. Now the demo app works, so my problem may have been trying to run on too old a machine.

| improve this answer | |
1

The problem is that the Ubuntu SDK makes use of OpenGL ES to render widgets, because it can use hardware accelerated graphics for it even on mobile devices. VirtualBox, however, doesn't currently support OpenGL ES in it's virtual GPU, so it can't run any Ubuntu SDK apps.

| improve this answer | |
0

For me , the black box was an error in the code , usually the UI part, look in the debug Qt Creator gives you and make sure you are using QML Scene (just to double check)

| improve this answer | |
-1

As far as I can see on the page of the currency converter app you need Ubuntu 12.10 instead of 12.04 (which I think is quite awkward btw).

I would start with upgrading to 12.10 and then try again..

Good luck!

ps. I am also starting to look into developing an app for the Ubuntu Phone.

| improve this answer | |
  • 1
    No need of 12.10 , my self tried in 12.04. – rɑːdʒɑ Feb 18 '13 at 13:39
  • That's correct but there were some problems using 12.04. See this thread. – Phidelux Feb 18 '13 at 22:37
  • I upgraded to 12.10. The problem did not go away. – Ken Young Feb 19 '13 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.