I'm dual booting W7 and Ubuntu (installed from Wubi). I've had it up and running a few times but today I'm getting a message from Windows Boot Manager when I select Ubuntu that wubildr.mbr is missing or corrupt. Any help would be greatly appreciated.

  • @creade So you're using windows boot loader to load linux? as opposed to using grub(2) to load windows? – xenoterracide Sep 13 '10 at 20:56
  • Is Ubuntu on the same drive as Windows, or external? Are you using anything special on your disk, such as encryption or RAID? – Jacob Peddicord Sep 15 '10 at 1:33
  • @xenoterracide wubi - is a weird way to install ubuntu - inside big file on windows partition so there's no other options, I guess. – Alex Bolotov Dec 22 '10 at 19:06

It is a general problem that happens with WUBI.Since Ubuntu is installed to a file inside windows partition,it becomes susceptible to corruptions that generally happen in Windows.You can reinstall Ubuntu but I recommend a full install.

| improve this answer | |
  • I did a fresh install and it seems to be working fine now. – creade Sep 17 '10 at 16:51

I can't test this but first use bcdedit from an elevated command prompt to find your Ubuntu partition and its identifier. Then try:

bcdedit /set {<ubuntu_id>} device partition=<ubuntu_part>:
| improve this answer | |
  • I gave this a shot but the partition was already set correctly in bcdedit. – creade Sep 14 '10 at 15:42
  • 1
    Have you tried this? – gvkv Sep 14 '10 at 16:57

I encountered that error in one of my Wubi installations on Windows 7. Near as I can tell, it was just a hardware quirk, since I don't see that error anymore now that I've installed on a different (desktop instead of a laptop) machine.

And even when the error popped up, everything still worked fine. It just took a couple minutes to work past the error message and then the boot process continued as normal.

| improve this answer | |

In C:\ubuntu\winboot you will find a copy of wubildr and wubildr.mbr.

Copy them to C:\ and restart the system.

| improve this answer | |
  • be careful if the ubuntu folder is on another partition – Duc Tran Aug 6 '11 at 0:34

I had a similar problem.

I had installed:

  • Windows xp
  • Windows 8
  • Ubuntu

When it comes to the BOOT panel, I choosed Ubuntu directly and got this message. BUT!! When I whent to "Windows xp" to could try the suggested option by: "enzotib" about moving it to another Directory inside Windows.

Following happened:

  • On the BOOT panel i choosed "Windows xp"
  • A "NEW" different format BOOT windows apear with just 2 options:
  • Windows xp? o Ubuntu? (Windows 8 did not apear on this new BOOT panel)
  • I choosed Ubuntu and installed fast and simple!

Hopes helps someone in the future to "Don't freak out"! Best regards, from Barcelona

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.