Yesterday I set up Ubuntu on a 32GB Sandisk flash drive. I booted it up on my Windows 7 PC, and it works flawlessly. I haven't had any problems getting it to boot with USB priority on that machine, or accessing any data stored on the partition its using. Then I tried plugging the same USB into my Windows 8 laptop. I changed the BIOS so that USB has priority, but it still booted straight to Windows 8. I tried 3 different USB ports, and none of them worked. Does anyone know if any settings on Windows 8 might be affecting this, or what I may be doing wrong? I can post a picture of my BIOS if anybody cares to see.

This is the laptop I am using

  • I am having the same problem with my samsung, similar laptop with same bios/UEFI configuration. I have read all the above links and tried everything. I turned off secure boot, tried CSM (legacy) and UEFI boot (samsungs have the option to do either/or) Then I set priority to boot from USB (I have 3 different usb versions, usb cd, usb hdd and usb something else) I have tried all 3 of these to no avail. I downloaded ubuntu 12.10 and used universal usb installer. My computer still loads just windows 8. The only small success I have had trying to install a linux os to my computer with windows 8 is – user137615 Mar 4 '13 at 20:38
  • I'm having the same issue here as well. i have a 32 bit Windows 7 machine. And I want replace my Windows with Ubuntu via booting from USB. Any clue or solution? – Muhammad Maqsoodur Rehman Feb 26 '17 at 15:52

You're not doing anything wrong, exactly - sometimes Ubuntu has trouble with the new UEFI technology, which your laptop has.

You can see instructions for installing and using Ubuntu on a UEFI PC here at the Community Ubuntu Documentation site. Basically, you want to burn your Live USB (preferably with Ubuntu Secure Remix, but regular Ubuntu should work as well), and before you try to boot from it, look in your BIOS for something that says "FastBoot/QuickBoot" or "Intel Smart Response Technology/SRT" and disable it. "Secure Boot", if you have it, might also have to be disabled. You should be able to install Ubuntu as normal from there, but if you reboot and get no Grub menus or you boot straight to Windows (or other boot problems), then you want to boot from your Live USB again and run Boot-Repair.

If you still have problems, then post back here.

| improve this answer | |
  • I disabled fast startup in Windows and do not have Fastboot, Quickboot, or SRT options in my BIOS settings. My computer boots straight to Windows. I have Secure Boot disabled. Any idea how I can fix this? – Kecoey Jan 14 '15 at 0:20
  • @Kecoey Please search for another existing answer, and if you do not find one start a new question - but do double check the boot order if you haven't already. – Richard Jan 14 '15 at 0:27
  • Yeah I have Windows as the lowest in the order and I have tried like 10 different guides. Thanks for responding though, I will keep trying – Kecoey Jan 14 '15 at 0:35
  • Yeah do try a question here, including your laptop model – Richard Jan 14 '15 at 0:36

Both 12.04.2 LTS and 12.10 should work with UEFI Secure Boot.


| improve this answer | |
  • 1
    Should being a key word. – Richard Feb 24 '13 at 4:04

It depends on which Ubuntu version you are using. If you are using Ubuntu 12.04.2 or 12.10 and beyond, then it should work; otherwise, you will have to switch back to legacy-BIOS. If you search how to boot older Operating systems in UEFI Secure Boot, you will find the answer you are looking for, but it will require a lot of risky tinkering. If it wasn't for the whole UEFI thing, I would have moved permanently to Linux instead of being stuck with this Windows 8 thing that I don't even like.

Anyway, have fun and God bless.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.