I got this error while installing ubuntu-restricted-extras:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So I ran that in terminal:

vennesa@vennesa-ThinkPad-R61:~$ sudo dpkg --configure -a
Setting up update-notifier-common (0.126) ...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.270.orig.tar.gz

Since then I can't install any thing. What do I do?

  • What is the output of sudo apt-get update?
    – Lucio
    Feb 17, 2013 at 20:04
  • I had faced same issue earlier. I simply disconnected from network.lol
    – g_p
    Oct 16, 2018 at 21:11

4 Answers 4


I find out an easy way, if sudo dpkg --configure -a wasting so much of time in installing your file just give abort the process and give sudo dpkg --remove -a it will remove all the uninstalled files and if you want you can install it again by giving sudo apt-get install your_soft_name.


Upon returning to installing Gnome via sudo apt-get install ubuntu-desktop, that was cut off by a power outage and I experienced exactly this issue.

I chose to issue the sudo dpkg --configure -a and then lost my terminal window forever in Windows Hyper-V 2012 manager. I was able to connect to my Linux box using SSH (PuTTY) from my Windows 7 Pro client though no problem.


After searching a lot I got a satisfactory result:

I found some places saying to run commands:

sudo apt-get install -f
sudo dpkg --configure -a 

But none of those above worked.

The solution that worked for me:

sudo dpkg --configure --pending

Hope I have helped.

  • This worked for me in the case where the problem was a full disk, whereas dpkg --configure -a would just complain about that same problem without fixing anything. Nov 9, 2021 at 12:09

If I understand correctly, you believe the terminal is freezing/not working once that flasplugin-installer: line appears.

However, Adobe Flash is a proprietary program with a license that doesn't allow direct distributing by Ubuntu. Because of this, flash updates using the flashplugin-installer, which downloads and installs the latest version of flash onto your computer.

So, when you see this line, and it doesn't appear to be doing anything, the terminal is actually downloading the latest version of flash flash. Wait a while, and it should continue.

  • You can also run sudo apt-get install --reinstall flashplugin-installer. Some time ago the installation of that package fail to me. The download did finish correctly and the flash doesn't downloaded altogether. Reinstall was the solution for me.
    – ssoto
    May 22, 2013 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.