I have a Dell Vostro 3360 with 500GB+32GB SSD and I've installed dual boot Windows 7/Ubuntu 12.10. Everything worked fine till I upgraded the kernel version as I noticed that Windows 7 from GRUB menu disappeared.

I've tried several ways and hours to solve it but, I cannot make Windows 7 boot again.

Boot-repair (from Ubunutu or LiveCD) didn't solve the issue as it seems it doesn't see the Windows installation. Here it is the pastebin:


I even added manually the entries using Grub Customizer to boot directly from /sda3, but the error returned is "bootmngr is missing". Using a windows 7 recovery disk, the Startup Recovery option doesn't solve anything. Also, it doesn't see the previous Windows installation. The windows partition is already active (marked as boot) as I tried the solution from other posts.

Restoring MBR using Boot-repair for the first time, I was able to resume Windows (hibernation), but after shutdown I was no more able to boot in Windows. In that case, I think the Intel Rapid Start it was used as it for hibernation. Thus, I'm pretty sure that this technology is messing up the grub and booting as Boot-repair reports:

============================= Boot Info Summary: ===============================

 => Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    in partition 1 for (,msdos5)/boot/grub.
 => Windows 7/8/2012 is installed in the MBR of /dev/sdb.

(sdb is the 32GB SSD).

As a last chance, I've even tried restoring the Dell factory image, but besides wiping my Windows, it didn't help at all.

Right now, I am out of solutions. If somebody has other ideas to try, it will be much appreciated.

Thank you!


Might be you want to try manual edit the grub.cfg while waiting for other professional to answer your question.

Below are my Windows 7 entry in the grub.cfg, I hope that can be a reference for you when editing:

menuentry 'Windows 7 (loader) (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-D4665DF6665DD9B6' {
insmod part_msdos
insmod ntfs
set root='hd0,msdos1'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  D4665DF6665DD9B6
  search --no-floppy --fs-uuid --set=root D4665DF6665DD9B6
chainloader +1
  • thanks for the answer, but I've already add manually the menu entry: menuentry "windows 7.3"{ set root='(hd0,3)' search --no-floppy --fs-uuid --set 36ECF4D1ECF48C7D drivemap -s (hd0) ${root} chainloader +1 } Anyway, I'll try to add yours with the necessary updates for sda3. One issue seems to be that grub doesn't see the Windows installation even if I disabled from BIOS the Inter Rapid Start and set AHCI... – vicxyz Feb 17 '13 at 11:42

can you mount sda2 or sda3?

sudo mount /dev/sda2

can you see any of the nodes sda2 and sda3 in the /dev directory?

ls /dev/sda*

if not, try:

sudo apt-get install dmraid
dmraid -an
dmraid -si
dmraid -E -r
sudo update-grub


  • Yes, it was just for the pastebin, I ran it several times without effect. Also, update-grub : Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.5.0-23-generic Found initrd image: /boot/initrd.img-3.5.0-23-generic Found linux image: /boot/vmlinuz-3.5.0-17-generic Found initrd image: /boot/initrd.img-3.5.0-17-generic Found memtest86+ image: /boot/memtest86+.bin done – vicxyz Feb 17 '13 at 14:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.