When I start Ubuntu and chose one of the settings it says:

/casper/vmlinuz: not found

I have Ubuntu on a USB drive. I used this USB creator: http://www.linuxliveusb.com/

I have done this 2 times now and the same thing happens. What can I do?

I even checked my casper directory. It has the vmlinuz file but it still reports the same error.

  • 1
    You said, "or something like that." What's the complete, exact error? Did you MD5SUM the ISO to see if it's good? If not, please do so and report the results. (If it's bad, download it again, and MD5 the new one too.) What happens when you try writing Ubuntu to the flash drive using the Universal USB Installer? If that doesn't work, what happens if you try writing it with UNetbootin? Please edit your question to add this information. – Eliah Kagan Feb 17 '13 at 0:31
  • I had the same problem today and it seems the current version of ubuntu-12.04.2-desktop-amd64.iso is missing the /casper/vmlinuz file. It only has a vmlinuz.efi which is for UEFI systems as i understand. – Stroboskop Feb 20 '13 at 0:12

I also had the same problem with a daily built of Ubuntu 13.04.

The problem seemed to be that the file in /casper/ was named as "vmlinuz.efi" instead of "vmlinuz" -without ".efi" - which it was looking for.

After removing the ending (.efi), Ubuntu procceded without any implications.

| improve this answer | |
  • it worked for me. thx! – unludo Mar 10 '13 at 11:35
  • I had a similar issue, but file was named vmlinuz, so I added .efi extension and it worked. – Milan Todorovic May 20 '13 at 14:51
  • 1
    I em installing by ISO (CD-ROM), so... what I can do? what the procedure? – Peter Krauss Oct 6 '15 at 17:59
  1. If the message is /casper/vmlinuz: not found you can perhaps open the usb drive and check if it has a directory named "casper" and it contains a file named "vmlinuz", and if this file is not there, probably something went wrong, and perhaps it can work if you can open the iso file (which is a packed file in deed) and extract it from there.
  2. You can try another usb live creator like this one: www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.