I have a laptop with Ubuntu 12.04 LTS on it.

I paired a Bluetooth mouse with it, which caused the touch pad on the laptop to stop working.

After the computer was suspended over night, I tried to use the mouse when it said:

Mouse is trying to access your computer, grant access?

But I can't click the buttons as now neither the touch pad nor the mouse works.

I can't alt+ tab to the window as it opens under the other windows and does not show in the list.

I tried enabling mouse control via the keyboard using Universal Access but I don't have a keypad on my laptop.

  • What is it when you say you don't have a "keypad"? – jobin Feb 24 '13 at 22:11
  • The image you posted doesn't seem to clarify much, can you be a little more verbose or post a better picture? – jobin Feb 24 '13 at 22:40
  • @Jobin as in a laptop doesn't have the 0-9 /*-+. enter, num lock keys on the right of the keyboard, like a normal desktop keyboard. The "Universal Access" setting binds these to move the mouse. But because I don't have them I still cannot move the mouse. – Petah Feb 25 '13 at 1:22
  • Did you get your problem solved, Petah? – don.joey Feb 27 '13 at 8:59
  • @Private yes, but I did not try your solution. Out of luck, some how the window got focus (no idea how it happened), and then I used the keyboard to click the button. I will let the bounty run a little longer, then you will get the points. – Petah Feb 27 '13 at 17:10

Good question. Here is a workaround.

  1. Open a terminal. Use the windows key to open the HUB and type terminal and use the arrows keys to open a terminal.
  2. Type the command xinput in the terminal. That will give you a list of the input keyboard and pointer inputs on your computer. It will look something like the table below.
  3. Find the entry that says touchpad and enable it as follows. You can enable it by typing xinput set-prop 12 "Device Enabled" 1 (set-prop means set the property and the 1 means put it on). To switch it off, for instance, you would use xinput set-prop 16 "Device Enabled" 0.
  4. Hit the button you want and enjoy control over your computer. Find out whether the error occurs again. If so, google, ask a question here or file a bug (in that order).

This is the table you will see in step 2:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_1.3M             id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=13   [slave  keyboard (3)]

This is a comparable question: How to disable the touchpad?

| improve this answer | |
  • It's good manual, but could you explain please, what is 16 in this command xinput set-prop 16 "Device Enabled" 1? Why exactly 16? Touchpad id is 12. That's why I' asking – titusjaka Feb 26 '13 at 12:28
  • Good question, the 16 in this example should 12. It is 16 on my system and could be something else on your system. – don.joey Feb 26 '13 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.