0

I restored my iPod on a friend's Mac using iTunes. When plugging in my iPod now, it's mounted as read-only and I have no way to transfer songs (using Rhythmbox or Nautilus). I've tried changing the permissions by hand but no luck. Information on the internet is outdated and does not apply to my iPod Classic 6th generation.

2

Most probably your iPod has an HFS+ filesystem. In order to make it work on Ubuntu you should:

  • disable journaling
  • get your music / iPod manager to write on the device

You can disable the journaling from OSX with just a couple of commands, see here, apparently it is possible to do this from Ubuntu itself.

Now you can write on the iPod as root only (or as a user whose UID is the same as that of the user owning the iPod on the Mac). To execute a Gnome program from your launcher as root for example, see here (in Xubuntu you can just use the menu editor).

1
  • Thanks for the answer. I ended up putting Rockbox on my iPod and can't check if your solution works but hopefully it can be of help to others. – duxk.gh Feb 9 '17 at 12:36
0

Temporary solution. From a terminal, run the command:

gksudo nautilus

You should have permissions from there so you'll be able to transfer your songs. Also, try to change the permissions from the gksudo nautilus (: .

Hope I helped (you said you used nautilus, you mean with gksudo? I just was unsure).

Also, second thing if you'll need, check the Ipod's partition/s with GParted.

7
  • sudo, gksudo, it's only a matter of entering the password in textual way or a graphic one (: – yinon Feb 16 '13 at 22:24
  • I tried this already but it didn't work. Sadly you can't just transfer songs to an iPod using Nautilus and expect it to work. It uses some strange folder structure. Also I can't change the permissions, even with sudo, since I'm not the owner. I attempted to change the iPod's permissions on the Mac I used to restore the iPod with. This worked to the extent that "everyone" could read/write, but when it came down to transferring songs it didn't work. – duxk.gh Feb 17 '13 at 6:51
  • When I open nautilus using sudo and try to change the owner/group permissions, I get the following message: "The owner/group could not be changed. Sorry, could not change the owner/group of "iPod": Error setting owner: Read-only file system" – duxk.gh Feb 17 '13 at 6:59
  • Try GParted, does he give any clues? If he does, can you picture your screen and upload it here? – yinon Feb 17 '13 at 18:27
  • gparted gave me no clues. when selecting the ipod it just says it's "unallocated" space. – duxk.gh Feb 19 '13 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.