First of all sorry for my English, it's not my first language.

Here is what I have done:

I had a working ubuntu 12.04 with all updates and working bumblebee, so I could do optirun command and battery life was better than without bumblebee.

Than I decided to reinstall both my systems installed windows 7 and ubuntu.

Reinstalled Windows 7 all working as expected, than on other partition installed ubuntu 12.04. All worked perfectly. Than I installed bumblebee according to the procedure written here https://wiki.ubuntu.com/Bumblebee same steps that I used before.

But now after I install drivers and do all written in procedure and I reboot my notebook system won't boot, it is simply stuck at black screen after short showing of start screen.

I reinstalled ubuntu many times already and tried everthing, but when I try install nvidia drivers it won't boot after shutting down notebook and only thing I can do is reinstalling system.

I have Lenovo Thinkpad Edge E530 and processor: Intel® Core™ i5-3210M CPU and graphic cards are Intel HD 4000 and Nvidia geforce gt630m

After clean install without bumblebee, terminal command lspci| grep VGA is showing:

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)

01:00.0 VGA compatible controller: NVIDIA Corporation Device 0de9 (rev a1)

Can you suggest a sollution?? Or at least some links to similar topics??


Ubuntu 12.04.02 ships with a Hardware enablement stack. Basically this is a stack providing kernel/xorg from Quantal (packages linux-generic-lts-quantal and xserver-xorg-lts-quantal) to improve hardware support.

What probably happened when you installed Bumblebee is that, because it depends on the default Xorg stack, xserver-xorg-lts-quantal was removed and replaced with xserver-xorg, and those two stacks don't seem to work well when mixed.

To fix this you need to boot in text mode. The easiest way is to achieve this is pressing E when you highlight your Ubuntu entry on Grub. This will let you edit the entry (non permanently). There you should see a line similar to this:

linux   /boot/vmlinuz-3.5.0-23-generic root=UUID=(...)  ro   quiet splash $vt_handoff

Replace the quiet splash $vt_handoff with text and press Ctrl+X. This should boot you in text mode. After login you have to choose what to do next:

  1. Revert the changes you made: this will remove Bumblebee and let you start your system again. You will only be able to install Bumblebee without breaking the system when someone fixes Bumblebee dependencies

    sudo apt-get install xserver-xorg-lts-quantal linux-generic-lts-quantal
  2. Remove the Hardware Enablement stack. This will let you install Bumblebee.

    sudo apt-get install linux-generic xserver-xorg

Either one of those options will install a lot of packages and remove others, so you will need to have internet access. Also if you have important information make a backup before you proceed.

I had the same problem and used the second option, and everything works now. I have not tried the first option, but it should work as well.

  • Thanks for reply, I will try it ASAP. I don't have time now because of school. – malarkey25 Feb 22 '13 at 14:16
  • I tried your advices but it didn't worked. But you are right, it was because of hardware enablement stack packed with ubuntu 12.04.02.. So I downloaded ubuntu 12.04.01 from old-releases.ubuntu.com/releases and all is working now :)) Thank you very much for your reply – malarkey25 Feb 28 '13 at 23:15
  • I ran into exactly that problem just now, and blindly fixed it by reinstalling the "old" xserver. @Andrej you should really select Salem's answer as the correct one. – Charl Botha Mar 12 '13 at 20:06
  • Selected as correct...sorry forgot about it... – malarkey25 Mar 15 '13 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.