19

How to achieve List/Tree view in Nautilus like the following screenshot?

http://i.stack.imgur.com/mKSOd.png

Cant find information about this. ps
Im using Ubuntu Remix with pure Gnome 3, and last version of Nautilus.

  • Definitely not - there is no even word 'tree' on that page. – Gill Bates Feb 16 '13 at 19:20
  • Well, maybe you right about naming, but anyway point of my question is different than in one by your link. – Gill Bates Feb 16 '13 at 19:31
  • They've decided to remove the 'tree like' view. – klokop Jul 18 '13 at 12:44
12

This is the "List View" in Nautilus up to v3.4 (shipped with Ubuntu 12.10). It's no longer available in Nautilus v3.6

You can activate it in the "View" menu:

Screenshot of the Naulius View menu

| improve this answer | |
  • 9
    Sadly that they removed this feature. – Gill Bates Feb 16 '13 at 19:21
  • 2
    @Aditya in modern version (which i use) Nautilus list-view does not provide tree-view: i.imgur.com/5YqccTA.png – Gill Bates Feb 16 '13 at 20:00
  • 24
    Why, god oh why, was this feature removed? What was the reasoning? Am I alone in finding these constant dismaying decisions infuriating? My energy has just been zapped by this. Desperate. I want to rage quit. I forgive you Windows. The next time I feel the urge to complain about you I will try my very best to bite my tongue. – Gerard Roche Jul 31 '13 at 23:33
  • 1
    @BullfrogBlues second you – Bleeding Fingers Aug 25 '13 at 15:43
  • 8
    Yes, the feature was reinserted since version 3.7.90: Add back a Treeview option for list view. This is off by default, and is backed by a checkbox in the Preferences dialog (source) – franzlorenzon Jan 2 '14 at 14:04
33

You can do this in the Nautilus (Also called "Files") preferences window. Here's how:

  1. Make sure you have "Files" (program) running (or else the menus will NOT bring you the correct sub menus when you click on them)

  2. Click Edit > Preferences

  3. On the Views tab, select the List View viewing option next to "View new folders using:" and click close.

You're done!

Nautilus preferences window

| improve this answer | |
  • 5
    This used to work, unfortunately I can not find this preferences dialog in 13.04. I used gsettings set org.gnome.nautilus.preferences default-folder-viewer 'list-view' instead. – wim May 2 '13 at 2:12
  • 1
    This functionality has been restored in 13.10 – Dakota Feb 26 '14 at 20:04
  • Also, in the Files app in the menu Edit->Preferences Under the "Display" tab you want to check the "Navigate folders in a tree" checkbox – hobs May 8 '15 at 2:25
21

gsettings set org.gnome.nautilus.preferences default-folder-viewer 'list-view'

Options are 'list-view', 'icon-view' and 'compact-view'.

| improve this answer | |
  • just what i was looking for, works great (can you tell me where I can find more info) – Remus Rigo May 6 '12 at 11:00
  • How to make this setting have a permanent effect? It is not permanent on 14.04 (not for me). – the_prole Feb 16 '15 at 19:09
  • 14.04 click the settings "gear" on the right, then you'll find the Preferences in which you can select the list view. – user346530 May 20 '15 at 12:01
17

The tree view can be enabled from the files > preferences. There is a check box for this.

Version : 3.8.2

enter image description here

| improve this answer | |
11

Open Nautilus go to Edit ► Preferences then under Display tab checked:

List View
enter image description hereNavigate folders in a tree

enter image description here

And also In Views tab select "List View" mode and close. Close and open Nautilus again see the changes.

enter image description here

| improve this answer | |
5

Ubuntu 17.10 and 18.04

  1. Enable list view: Click the list button at top right. (It will change to a four-squares button, for going back to icon view.)
  2. Enable tree view: Go to Files menu -> Preferences -> Views tab -> under List View, enable Allow folders to be expanded

Or via CLI

  1. Enable list view

    gsettings set org.gnome.nautilus.preferences default-folder-viewer 'list-view'
    
  2. Enable tree view

    gsettings set org.gnome.nautilus.list-view use-tree-view true
    
| improve this answer | |
3

In nautilus-3.6 (raring), it's gone though I've added back along with several other changes in a ppa https://launchpad.net/~mc3man/+archive/nautilus-hacks

In 3.8 or higher it's been returned, enabled thru - click on files > preferences > Display > & enable there.

| improve this answer | |
0

You can activate the tree view, called as "list view" by clicking via View -> List.

The same can be done by pressing Ctrl + 2 To revert back press Ctrl+ 1

List view

| improve this answer | |
0

Ubuntu 18.04 gnome-shell 3.28

Use this command:

gsettings set org.gnome.nautilus.list-view use-tree-view true
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.