7
Boot from (hd0,0) ext3   238ac8ca-9576-443d-8e23-8dd836cd2683
Starting up ...
mount: mounting /dev/disk/by-uuid/238ac8ca-9576-443d-8e23-8dd836cd2683 on /root
failed: Invalid argument
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have requested /sbin/init.
No init found.  Try passing init= bootarg.


BusyBox v1.15.3 (Ubuntu 1:1.15.3-1ubuntu5) built in shell (ash)

Enter 'help' for a list of built-in commands.
4
  • 1
    Why a bounty, given the asking user is not seen on askubuntu from "Feb 12 at 16:04"? – enzotib Aug 26 '11 at 20:08
  • 2
    But i need the answer for this, as i faced this issue few months back. – karthick87 Aug 27 '11 at 4:04
  • @karthick87: but are you the same user as @user10593? if not, why not open a new question, we cannot get anymore details from the asking user. – enzotib Aug 27 '11 at 11:37
  • Lol i am not that user. I thought that the existing user was regularaly using this site.. – karthick87 Aug 28 '11 at 5:43
11
+100

Try the steps listed in this page:
How to Fix an Ubuntu Error: "No init found. Try passing init= bootarg"

Basically,

  • Reboot with a live CD
  • sudo fdisk -l

will get you the name of the disk then

  • sudo fsck /dev/sda
4
  • 1
    for me it was sudo fsck /dev/sda1, but worked a champ, even though it couldn't mount. sweet! – rogerdpack Nov 22 '13 at 19:04
  • What does fsck do? In general and in this case. That is also not explained in the source provided. – Mads Skjern Jul 27 '15 at 17:39
  • fsck = file system check – Rumbles Apr 13 '17 at 12:10
  • worked! For me, the check has to be done on /dev/sda6 which is the system partition in my case . Answer "y" to all question during the check. – laugeo Oct 4 '17 at 7:49
1

For me, I just created ran the Ubuntu Boot Repair disk and it fixed everything!

0

Boot loader tries to boot from a partition which is not a correct linux root. Would you please provide more information?How did it happen?

If it happened after an unexpected shutdown (just a guess) maybe file system check can help you: http://members.iinet.net.au/~herman546/p10.html#filesystem_check_on_an_ext3_filesystem

1
  • It did happen after a unexpected shutdown. The link doesn't look like mine screen. – user10593 Feb 12 '11 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy