I am unable to change my screen resolution in my ubuntu 12.04. My default screen resolution was 1366x768. I had executed nvidia-xconfig to activate NVIDIA driver. Since then my screen resolution has stuck on 640x480.
I have tried going to Display settings, but it shows only one option in the drop down menu.
xrandr -s 1366x768 is also not working.
Please help. Thanks in advance.


Have you tried changing the resolution from NVIDIA's display configuration panel? Remember to run it as 'sudo' in order to save your settings:

1) Hit alt-F2

2) type gksudo nvidia-settings and hit enter ('gksudo' is the GUI version of the 'sudo' command in the terminal; alternatively you could open a terminal window and type "sudo nvidia-settings").

3) Select the resolution you want then hit apply, and if it looks good, click save to x-config

If nothing happens when you try to run the nvidia-settings program, perhaps you need to download and the latest drivers from NVIDIA's website.

Let us know how that goes.

  • Thank you for your response. Here is what how it went: ![This is what I got when I entered nvidia-settings as root][1] I suppose it means my nvidia-xconfig didn't quiet work as expected. Nevertheless, I am unable to change screen resolution through system settings. Also, there is no resolution option in nvidia-settins window ![This is my nvidia settings window][2] [1]: i.stack.imgur.com/pOLig.png [2]: i.stack.imgur.com/TBfME.png – stranger_anon Feb 16 '13 at 16:18
  • Maybe a silly question, but you did run nvidia-xconfig as sudo, right? I've never seen it blank like that; have you tried downloading and installing the latest drivers from NVIDIA? – natecornell Feb 16 '13 at 19:42
  • yes. I did run it as sudo. Also tried installing latest drivers from NVIDIA. Didn't make any difference. – stranger_anon Feb 17 '13 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.