This is not a duplicate of this or that!

The problem in detail

The brightness hotkeys works well in increasing or decreasing the brightness, but if the brightness is less than 100%, after a reboot the brightness level and actual backlight will mismatch; where I mean the actual backlight is not at its maximum while the brightness level shows 100%. To avoid such problem I should set the brightness level at 100% every time before shutdown.


I’ve tried all suggested answers for brightness problems, including acpi_backlight in grub and echo values in rc.local, but no change. Recently I found that pressing brightness hotkeys while brightness settings window is open sometimes make the brightness slider disappear!

I’ve had this problem after 11.04, I mean in either 11.10, 12.04 and 12.10, and saw in various netbooks and laptops. I guessed it should be related to unknown graphics driver; because I had a known driver in 11.04 and no problem, but an unknown one in all computers with this problem:

Unknown graphics

So I just tried 13.04 via USB and faced the same problem although the graphics was known:

Known graphics

A possible cause

In the folder /sys/class/backlight there are two links (to folders):

  1. acpi_video0 which contains brightness files with the maximum 15;

  2. intel_backlight which contains brightness files with the maximum 125. I wonder that in this folder brightness is 125 (at maximum) but actual_brightness is 70, even if the backlight is at its actual maximum.

Does anyone know about this or any possible solution?

1 Answer 1


The solution is updating grub such this:

Open a terminal (Ctrl+Alt+T) and enter:

sudo gedit /etc/default/grub

Then find the line GRUB_CMDLINE_LINUX_DEFAULT="quite splash" and add "acpi_osi=Linux acpi_backlight=vendor" like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Save and exit the file, and run:

sudo update-grub

Now the brightness level stays equal to the actual backlight level after reboot, and brightness hotkeys remain working. All other hotkeys which were working before grub changed are working now, but the hotkey for enabling/disabling touchpad.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .