22

This was an official 64-bit download from the Ubuntu site, so it's kind of sad to see even that's not working.

I made a bootable Ubuntu 12.10 USB stick with USB Image Writer (mintstick) on Linux Mint 14 Cinnamon and then shut down after ejecting the drive. When I put the drive back in and boot from it, a message shows briefly: 'isolinux.bin missing or corrupt,' before going black and booting to Mint.

I have tried Unetbootin instead of Mint's USB Image Writer but the USB drive does not show. Unetbootin has not worked for me in the past anyway whenever creating live USBs.

USB is formatted to msdos. Did not tamper w/ partitions, etc. in GParted, Disks, etc.

I have seen this issue asked once before on this website and other times across the web, but no one gives a good answer other than it's probably a bad download. If so, it's pretty disappointing because this is the official Ubuntu.com download link.

Any ideas? Are there any other alternate download mirrors besides the official one (that don't take hours to download)?

  • 1
    This likely relates to the bootloader not matching the kernel being loaded by Ubuntu 12.10. Have you tried with 12.04 LTS? Have you checked the download, using MD5 checksum? – david6 Feb 16 '13 at 5:59
  • Have you done an md5sumand make sure that the USB drive is Fat32 formatted. – Mitch Feb 16 '13 at 5:59
  • 1
    In case you have download problems, you can try jdownloader instead of looking for alternative sites, which might be risky. – Sadi Feb 16 '13 at 11:35
35

I came across this problem(isolinux.bin missing or corrupt) recently. The flash disk is made by dd, the iso file is of 12.04.3 64 bit. I fix this by change BIOS setting: change

USB Flash Drive Emulation Type

from 'auto' to 'hard drive'. Hope this helps.

  • 1
    This solved the same issue for me when booting a Dell 1950 server. Thank you. – scottro Oct 22 '15 at 16:45
  • 1
    This doesn't help for me. – smwikipedia Mar 14 '16 at 15:12
  • @smwikipedia How it fails? – accuya Jul 29 '16 at 1:31
  • accuya's answer solves that error on Dell R200 for me – kenneth558 Oct 7 '16 at 15:42
  • 2
    Works on dell sc1430, thanks. After hitting F11 on boot you now have to click HDD instead of usb! – Tim Abell Mar 4 '17 at 1:41
11

You may need to use the following command

sudo dd if=linux.iso of=/dev/sdb

instead of

sudo dd if=linux.iso of=/dev/sdb1
  • Well, it wouldn't work for me as I have two partitions on USB. First for live CD/DVD, second (larger) for data. – pevik Nov 30 '16 at 6:26
  • This worked for me. Thank you – Ahmed Hussein Dec 18 '19 at 19:09
2

I just came across this problem when trying to install any OS onto a Toshiba Satellite. I was finally able to get it working after disabling Fast Boot, changing from UEFI to CMS boot, and also using dd (from my kali mchine) after setting the file system type of the USB to fat32, and dd if=image.iso of=/dev/sda (after repeated failed attempts doing it on /dev/sda1)

2

I faced the same issue. But the solution was rather different from the answers already given (e.g. without changing BIOS settings or using extra-tools).

I've created USB-stick via dd command:

sudo dd if=linux.iso of=/dev/sdb

And got during boot:

isolinux.bin missing or corrupt

The stick I've used was not blank but contained some partitions before (as far as I can remember one of them was ISO9660 because I used the stick as Live-USB for past distribution). Those partitions were automatically mounted by file manager (Nemo) when I plugged the stick (dd command haven't complained about that).

I've unmounted those partitions and wrote linux.iso again. And got success on next boot from the stick.

0

I recommend this as the best solution to create a live USB:

  1. Use GParted to create a blank USB with FAT32 format.
  2. Install MultiSystem and use it to create a live USB from internet or from an iso file already downloaded.

(I've just created one from Ubuntu 12.10 64-bit iso file yesterday)

0

Might be a buggy BIOS ("firmware" to be more precise). Updating might help. Otherwise try UEFI mode instead of BIOS mode if available in the firmware setup. Or try a boot image that only supports BIOS systems. Good luck!

0

I am using dd for windows. And I encountered exactly the same issue with CentOS 7 DVD ISO. I checked the ISO checksum and it is downloaded OK.

Inspired by this article, I turn to use Fedora Live USB Creator. It can run into the installation UI of CentOS 7. But I am having trouble with the Error setting up base repository issue in the installation process. According to here, it is an issue of Fedora Live USB Creator. This is so far I have tried.

-1

Some folks may have just copied the ISO file to the stick hence the missing bin file. The ISO would actually need to be installed onto the USB stick via a program such as unetbootin. https://unetbootin.github.io/

Alternatively this could also be a permissions problem with ownership of the stick or the files and folders on it.

I wish you all the best of luck at sorting your issue out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.