I have the problem with my fan constantly and hot CPU. I have a Dell Inspirion 15r special edition. I followed the instructions to load Jupiter to solve this but when I enter:

sudo add-apt-repository ppa:webup8team/jupiter

I get the following error:

Cannot access PPA (https://launchpad.net/API/1.0/~webup8team/+archive/Jupiter) to get PPA information, please check your Internet connection

and Internet is working

My specs are:

Inspiron 15 R Special Edition,BTX,7520
Intel Core 3rd Generation Processor,I7-3612QM,  4Core
32G Solid State Drive,ISRT,A5
PWA,Daughterboard, SATA,7520
HARD DRIVE,1 Terabyte,5.4 krpm
8 GB Dual Channel DDR3 SDRAM
Intel (R) HD Graphics 4000
AMD Radeon HD 7730M
15.6 Full HD  1080 pixel LED Display

Ubuntu 12.10 is loaded as a dual boot alone on the 32 GB Solid State Drive.


For the error that you mention it is because the URL is wrong, if you try to get there you will get:

enter image description here

You actually want this URL: https://launchpad.net/~webupd8team/+archive/jupiter

So I suggest 2 things:

  1. First try to edit the /etc/apt/sources.list and see if the URL that throws you the error is found there. If it is, change it to the correct one and update your repositories afterwards.

  2. Edit your Software Sources. Simply open the Dash and type Software Sources. That should open the Software Sources window. On the second tab, the one that says Other Software find the PPA for Jupiter and remove that (Both, the source repository and the actual compiled repository for Jupiter).

    enter image description here

Then open a terminal, update your repositories again like:

sudo apt-get update.

Then proceed to add the Jupiter PPA shown in https://launchpad.net/~webupd8team/+archive/jupiter It should look like this when on the terminal:

sudo add-apt-repository ppa:webupd8team/jupiter

Then do sudo apt-get update to update the repositories again.

For the heat problem I would suggest:

  • Clean the laptop a bit (Just in case there is dust or something clogging the air flow)
  • Use the laptop in a position that makes sure it has enough space underneath it.
  • Anything that actually contributes to better air flow.

After you have solved the Jupiter problem (If you can not find it, just re-add the PPA using add-apt-repository it will take care of checking for anything missing. Maybe it had a problem when adding it the first time.

For the cooling part I also recommend using powertop. Install it by:

sudo apt-get install powertop

Then run the app like sudo powertop and go to the last TAB that has a column (The first column actually) that says BAD or GOOD. Go to all the ones that say BAD and start pressing SPACE to improve/fix them so they help in generating less heat and less power usage.

Last I want to point you to this question: How to control fan speed?

It has solved many users problems related to Fan speed: How to control fan speed?

Although again I would recommend checking into why the temperature is so high since the fan speed is higher, the higher the temperature of the CPU/GPU. So first check in Windows or physically the laptop for clean air circulation. Then proceed with the question.


Since you have a Hybrid Laptop (It means it has 2 video cards, an Intel one and an Ati one) I did some research and found some links that might help or give you an idea of where to go:

(Research about DELL Laptops and Fan problems)

Is Dell Inspiron 15R Special Edition compatible with Ubuntu? (Information about this particular model)

(A solution that might work with the Fan issues)

(Question about the same issue)

How do I get AMD/Intel Hybrid Graphics drivers to work?
(Fix for graphic problems. See NOTE1 for some additional information at the bottom.)

Dell Inspiron 15R [Special Edition] fan speed problem
(Link about checking BIOS for an option to remove one of the 2 video cards)

From all of this, the only one that actually went to where I was thinking was one that mentioned installing some Fan controlling packages (The i8k). I believe this could be a solution since it involves checking the sensors (Which also made me suggest to install lm-sensors). So here is a small guide to try it out:

  1. sudo apt-get install i8kutils

  2. sudo gedit /etc/modules

  3. Add in a new line i8k and save the file. It should look similar to this (Look at last line):

    enter image description here

  4. sudo gedit /etc/modprobe.d/options

  5. Add in a new line options i8k force=1 and save the file. It should look like this:

    enter image description here

  6. Reboot the computer. Type sudo reboot if you want.

  7. sudo gedit /etc/i8kmon

  8. Paste in the file the following information and save it:

(Copy the data and paste that in the file)

# Run as daemon, override with --daemon option
set config(daemon)      0

# Automatic fan control, override with --auto option
set config(auto)        1

# Report status on stdout, override with --verbose option
set config(verbose) 1

# Status check timeout (seconds), override with --timeout option
set config(timeout) 1

# Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
set config(0)   {{-1 0}  -1  55  -1  55}
set config(1)   {{-1 1}  55  70  55  70}
set config(3)   {{-1 2}  70  128  70  128}

# For computer with 2 fans, use a variant of this instead:
# Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
# set config(0) {{-1 0}  -1  52  -1  65}
# set config(1) {{-1 1}  41  66  55  75}
# set config(2) {{-1 1}  55  80  65  85}
# set config(3) {{-1 2}  70 128  75 128}

# end of file

Now reboot. Although before doing that, install lmsensors and make it detect every sensor you have:

sudo apt-get install lm-sensors

sudo sensors-detect

Wait for it to finish. Every time it asks for something press ENTER. After it finished asking about the summary it will tell you if you want to automatically create a file to cover all that was checked so it loads every time you boot the laptop, type Yes and press ENTER. Now reboot.

If the module does not load by any chance, simply type: sudo modprobe i8k force=1

If you want to monitor the Sensors, you could install the indicator-sensor which I found with the following PPA (I am pretty sure it was in the repositories in 11.10):

sudo add-apt-repository ppa:alexmurray/indicator-sensors
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install indicator-sensors

Now reboot and run the indicator sensor from Dash (Should appear in the panel).

NOTE1 - If you do the link above related to fixing the video, please download the packages from this link https://launchpad.net/~andrikos/+archive/ppa/+sourcepub/2909374/+listing-archive-extra the cover some fixes for Ati/Intel Hybrids.


I had this problem too, back in January when I bought my Dell XPS. Happily, after I installed Bumblebee and updated to the most recent Kernel version available, this problem has been fixed. Now it works like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.