I have a Broadcom 802.11 wireless pci card in my laptop, chipset 4318. I have followed all the instructions to replace the delivered driver with ndiswrapper with the appropriate Windows driver bcmwl5. I've just loaded Ubuntu so the kernel is 3.5.0-17. I had to use ndiswrapper-1.58rc1 to circumvent a problem with modprobe but now when I follow all the steps given for install ndiswrapper I get no errors but still no luck. Driver b43-pci-bridge is listed in /etc/modprobe.d/blacklist.conf but it is still the driver associated with the device according to lshw and I can't find any reference as to where that association is being made. When Ubuntu boots the wireless assistant button on the keyboard is not lit and I can't find any combination of keys or command to get it to light, I assume because the installed driver is wrong. So in short Ubuntu help - Wireless trouble shooting has used up the better part of 3 days but still not produced the desired outcome. Any ideas? I'm sure that if I could find out where that driver is being associated with the device I could make ndiswrapper work instead.


Ndiswrapper is the least desirable option, in my opinion. Please get a temporary wired ethernet connection, open a terminal and do:

sudo apt-get install linux-firmware-nonfree
sudo modprobe -r b43 && sudo modprobe b43

Your wireless should now be working.

  • you are a genius. It works fine. So why all this fuss on so many sites about ndiswrapper? (rhetorical question of course) If I had found this solution I wouldn't have wasted 3 days – Chuck Jowett Feb 17 '13 at 19:33
  • Many seemingly reliable authorities don't actually understand Broadcom devices as they are driven in Linux in 2013. I barely understand myself because a new chip seems to come out every week, including one new one that has NO way to get working, not even ndiswrapper. I am aware of no Broadcom for which ndiswrapper is the best answer. – chili555 Feb 17 '13 at 22:25
  • After I installed the latest updates I now have to re-issue sudo modprobe -r b43 && sudo modprobe b43 every time I re-boot. Any ideas what needs to be plugged? – Chuck Jowett Feb 23 '13 at 14:50
  • Please try this terminal sequence: sudo su; echo b43 >> /etc/modules; exit. Does it work now? – chili555 Feb 23 '13 at 14:58
  • nope, still not working – Chuck Jowett Mar 7 '13 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.