I realise that this question has been asked before, the best example being here (Unity doesn't load, no Launcher, no Dash appears).

I should mention I have never used Ubuntu before today, and it was working fine for a few hours before Unity (as I have learned it is called) disappeared.

My problem is identical to the OP of the above thread, however none of the solutions have changed anything for me. I am using 12.10.

unity and compizconfig-settings-manager are both installed.

Here are a list of commands suggested in the above thread that have failed:

  • ccsm in terminal, and then checking the unity plugin is enabled: it is
  • unity --reset when I do this command, terminal responds with 'reset function is now deprecated'
  • rm -rf .compiz-1 does nothing - terminal does not respond

Any suggestions would be greatly appreciated :)

6 Answers 6


Try this: open a TTY with Ctrl+Alt+F1. Login with your username and password. Stop the desktop with sudo stop lightdm, reinstall Unity with sudo apt-get install --reinstall unity and finish the dirty job with sudo start lightdm.

Remember to try it with a fast Internet! If you have any doubts or it just doesn't works, you can always reply me! :)

  • Unfortunately it didn't work :(
    – user132381
    Commented Feb 15, 2013 at 22:56
  • Have you tried to remove .Xauthority?
    – Xerz
    Commented Feb 16, 2013 at 11:51
  • How do I do that?
    – user132381
    Commented Feb 16, 2013 at 16:52
  • Open the TTY once again and do mv ~/.Xauthority ~/.Xauthorit_ (backup mode) or rm ~/.Xauthority (remove mode)
    – Xerz
    Commented Feb 16, 2013 at 19:25
  • Not a good experience for the 1st day! :(
    – Xerz
    Commented Feb 16, 2013 at 19:26

I had a similar but not identical problem and found a fix by merging solutions from several other questions here on askubuntu. Can you be more specific? When you say something "doesn't work", did you get an error message? Did the command run, but your problem still isn't fixed? If so, was there any feedback? Alternatively, did you input the command and quite literally it "does nothing" - your computer did nothing at all?

One of the things I did was to uninstall ccsm. I don't like it; those warnings it gives you about how you can really mess up your install if you fool with the setting? Yea paying attention to that would have saved me 6 hours.

Anyways when you run a command in the terminal there should be some feedback or a logfile output or something. It's going to be easier to diagnose the problem knowing that information.

  • Hi, thanks for the response. When I try unity --reset, there is an error message stating the reset option is deprecated. Literally nothing happens when I do rm -rf .compiz-1. And when it try the sudo stop lightdm and reinstall unity and restart lightdm it says unity is replaced but when I restart lightdm literally nothing happens. Hope that helps.
    – user132381
    Commented Feb 16, 2013 at 16:46

I'm on 12.04 and didn't realize the unity --reset was deprecated in 12.10. There is a solution posted here:

How do I reset my Unity configuration?

...but I haven't tried it personally because I don't use 12.10.

For the XAuthority issue you should probably look up a solution separately, and if you don't find a fix create a separate question. There is info on the boards on how to recreate your xauthority script and make sure the environment variable is set properly. When I had a similar problem, I had somehow removed read/write access to the necessary files and first had to restore that. So you might want to check first and make sure Xauthority is really missing and not just "missing" for you as user...


To debug your problem, you can try those steps:

  1. First of all you should test if your computer can run Unity:

    /usr/lib/nux/unity_support_test -p

    if you get any "no" that could be the cause of your problem.

  2. Try creating another account and login to Unity in it. In tty1 execute


    then select "User accounts", create a new user, activate it and login with it. If Unity starts then the problem is your configuration. If you get the same then there's really some problem with Unity

  3. After you login, switch to tty1 and execute

    unity --replace

switch to tty7 (Ctrl+Alt+F7) and see if anything changes. Also check for errors in tty1. If the output in tty1 is too long you can redirect the output to a file using

unity --replace > ~/unity.log 2>&1

and then open unity.log in your home folder and search for errors there.


I had pretty much the same problem under 12.04. Unity was slow with my aged GPU, so I was using Unity 2d as my desktop for months. For no apparent reason, it suddenly refused to display launchpad and title bar (for all users). Reenabling Unity in CCSM as sugggested in the thread referred to by OP was part of the solution, but none of the other measures suggested here, there or in several other related threads (including, but not limited to:

  1. Reinstalling unity

  2. Reinstalling ubuntu desktop

  3. Removing all relevant (e.g. compiz, gconf, etc.) configuration information

helped me to completely resolve these symptoms under 12.04 (64 bit).

unity --reset

would not work for me. After delivering a variety of error and information messages, it would always hang at:

Setting Update "run_key"

as shown in the log posted in the thread titled "unity has vanished" for unity run with no arguments.

I noticed that the error message delivered by:

/usr/lib/nux/unity_support_test -p

was similar to some of the errors reported by unity --reset:

error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

After extensive searching, I found the following solution:

  1. Get the path of libGL.so.1 by using the command locate libGL.so.1.

  2. Add a link to the library in /usr/lib/ as shown in the following example:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib

    (courtesy of J.D. Bartlett)

  3. Restart the computer.

This not only allowed both unity_support_test-p and unity --reset to run, it also allowed Unity 2d to start. Like the author of the above-mentioned post, I have no idea what caused my problems. I am also still not sure whether the link is a complete solution, or whether I should reinstall the graphics libraries completely, as described by Cynical here.


Press Ctrl+Alt+T and type the following command into the terminal that appears:

sudo apt-get install compizconfig-settings-manager

Then type:


In the CCSM window, select DesktopUbuntu Unity Plugin.

In the next window, make sure Enable Ubuntu Unitu Plugin is checked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .