Today I decided to finally try out Ubuntu, so I followed the Windows installation guide. I downloaded the Desktop Ubuntu 12.10 ISO for Windows, and used the Pen Drive Linux USB Installer to install Ubuntu on my external hard drive. When I rebooted my PC, nothing extraordinary happened. Then I went and changed my boot device order. There was two different entries including "USB", so I just moved one of them to the top, and when I chose save and exit, Windows just started normally again.

Then I went and tried moving the other entry including "USB" to the top, and moved the first one back. This resulted in a black screen with a line of text. The text said something including Syslinux, a copyright symbol, a name (Peter H. Avin or something) and two letters. Nothing else happened after waiting several minutes. I tried pressing several buttons on my keyboard, and at some point, every button started saying a "blunk!" noise. Waiting another fifteen minutes didn't do anything either, so I forced my PC to shut down.

I tried starting up the computer again, and it said that there may be a problem with the computer, maybe caused by recent hardware changes. It gave me 2 options, to start repairing the computer, or to start Windows normally. I started Windows normally, as I knew that this didn't need repair. When I tried going back to change the boot device order, and saw nothing had changed since last time, I just pressed "Save and exit", and got the black screen with the copyright line again.

I can't figure out what I'm doing wrong here to be completely honest. I installed Ubuntu on the right drive, and I've tried moving both of the entries including "USB" to the top in the boot device order, and neither of em helped me much. So what I'm trying to say is, I think I need help. What am I doing wrong?

2 Answers 2


I'm not sure about your problem. When you go to the boot menu, go where you said you changed the boot device order, but leave as it was before you changed anything. Under those options, their might be something else about boot system, go into that and change that into your USB boot. Hope this helps. Depends on your boot menu I think.

  • The problem is not in the boot order or in which device is selected for booting in the BIOS. The BIOS was able to successfully boot from the USB flash drive; once the boot process started successfully, the boot loader (SYSLINUX) then froze. Feb 15, 2013 at 21:25
  • Well in that I don't know. I didn't use SYSLINUX. I used the unetbootin which has GARB 2.0 I think. It's working fine but sometimes my monitor just loses signal randomly so I can't even install it. I get close to finish it but it just loses signal idk what's happin. Feb 15, 2013 at 21:39
  • SYSLINUX and UNetbootin are totally different kinds of things. You can never use one instead of the other. UNetbootin writes data to the USB flash drive. SYSLINUX is some of the data on the USB flash drive; in particular, it is the low-level program responsible for making the operating system on the USB flash drive boot. UNetbootin runs in Windows. SYSLINUX runs when no operating system is running at all. Feb 15, 2013 at 21:41

SYSLINUX ran, so you were able to boot to the correct device. (SYSLINUX is the boot loader that resides in the ISO image--and thus on your USB flash drive.)

But SYSLINUX did not succeed; it just froze.

The most likely cause of this problem is that the ISO file:

  • downloaded wrong, or
  • was not written enitrely successfully, to the USB flash drive

To see if the ISO downloaded correctly, check its MD5SUM.

If the MD5SUM is wrong, download the ISO again (and MD5 test the newly downloaded copy, too).

If the MD5SUM is correct, make sure you're writing it correctly to the USB flash drive. There is a procedure for testing the integrity of the data written to the USB flash drive, but unfortunately you won't be able to use it in this situation unless you have another computer, since your computer doesn't get far enough in the boot process to access the boot menu and choose to run that test.

You used the Universal USB Installer to write the ISO to the USB flash drive. If you can't get that to produce a working flash drive, try UNetbootin instead. (Similarly, people who try UNetbootin and have trouble with it can try Universal USB Installer to see if that works better.)

If it still doesn't work, try formatting the USB flash drive in Windows (right-click on it and click Format...). Use FAT32. Then try UNetbootin again.

If it still doesn't work, please edit your question to provide details about everything you did and what happened. In particular, please describe exactly how you wrote the ISO image to the USB flash drive.

Finally, you may want to test your RAM. Ordinarily you could do this from the boot menu on the USB flash drive, but you can't get far enough that this works. So, use the instructions on the official memtest86+ website. Attempting to test your memory in this way is helpful for two reasons:

  • If this doesn't work either, it suggests there may be a hardware problem (or systematic errors in the way you're creating boot media).
  • Assuming you are able to do it, it may reveal a defect in your RAM. Or it may not find one (suggesting that a defect is unlikely). RAM can go bad; it's worth testing under these circumstances.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.