How can I fix this? I can't update anything at all.

I've tried to switch to my best server in the options.

When I do sudo apt-get update, this is what I get:

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/quantal/Release Unable to find expected entry 'universe/binary-1386/Packages' in Release file (Wrong sources.list entry or malformed file) E: Some index files failed to download. They have been ignored, or old ones used instead.*

When I do sudo apt-get upgrade, I get this:

Reading package lists... Done

Building dependency tree

Reading state information... Done

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

the contents of my source.list:

deb http://ubuntu.mirror.rafal.ca/ubuntu/ quantal universe restricted main

....update: when I update, it looks for 'universe/binary-1386/Packages'

however, if I go to: ubuntu.mirror.rafal.ca/ubuntu/dists/quantal/Release with Google Chrome, I see that the file is actually named "universe/binary-i386/Packages" (it's with an i, not a 1) . how can I fix this and make it expect the proper package?

  • 1
    the 1st output shows you got problems with your source.list files. so please Post the content of /etc/apt/sources.list as for the 2nd output means you don't have more updates in Other words, the command is working fine. and check this Question to know what to post askubuntu.com/questions/112988/…
    – Suhaib
    Feb 15, 2013 at 3:33
  • this is my sources.list, it's pretty barebones: deb ubuntu.mirror.rafal.ca/ubuntu quantal universe restricted main Feb 15, 2013 at 3:36
  • open the terminal then type this command: gedit /etc/apt/sources.list . A new window will show up. Copy everything inside and paste it to your question. Use the edit button in this page so that you can edit your question and insert the copied contents
    – Suhaib
    Feb 15, 2013 at 3:39
  • I updated the first page, but yeah, the literal only line in my sources.list is: "deb ubuntu.mirror.rafal.ca/ubuntu quantal universe restricted main" Feb 15, 2013 at 3:43
  • I've also tried to replace my sources.list with a generated one... but it ends up defaulting to that one line Feb 15, 2013 at 3:44

2 Answers 2


It sounds like you've run dpkg --add-architecture 1386 at some point. If dpkg --print-foreign-architectures shows 1386, running dpkg --remove-architecture 1386 should fix the problem.

  • this worked, thank you so much! now I can finally start installing software. Feb 15, 2013 at 4:44

I just disabled the "ppa" lines in the "Software & Updates" app under the "Other Software" tab. It works fine now. It turns out that when I installed the Razer keyboard software (and google earth), that's when I started getting the error message described above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.