I installed Ubuntu Server 12.10 in a VM and tried to setup Juju following these guides:



How do I configure juju for local usage?

I'll put here the exact commands I used.

sudo add-apt-repository ppa:juju/pkgs
sudo apt-get update && sudo apt-get install juju
sudo apt-get install lxc apt-cacher-ng libzookeeper-java zookeeper
ssh-keygen -t rsa -b 2048
juju bootstrap
nano .juju/environments.yaml
mkdir whatever
juju bootstrap

enviroments.yaml after edited:

    type: local
    control-bucket: juju-831d06b0c3c94d4d816f0b70c37460ea
    admin-secret: 353b2c52ba144dd5b22dffbf8c69c833
    default-series: precise
    ssl-hostname-verification: true
    data-dir: /home/victor/whatever

When I run "juju bootstrap" I get this error:

2013-02-14 23:05:00,846 INFO Bootstrapping environment 'sample' (origin: distro type: local)...
2013-02-14 23:05:00,847 INFO Checking for required packages...
2013-02-14 23:05:01,408 ERROR SSH authorized/public key not found.

Thanks for any help!

  • When I generated public/private rsa key pair, I press 'y' instead of 'Enter'. The keys were created under $PWD instead of .ssh, so I got the same error. What is your ls ~/.ssh/ output?
    – wenjianhn
    Feb 18, 2013 at 13:34

1 Answer 1


Check to make sure that you didn't create it as root, because this way the .ssh directory will be placed in the /root directory. I made this mistake, but after copying the .ssh dir for /root to my default user directory, it worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.