I installed Lyx in my system, but it I just can't make it work. Every time I open any file, I get a message similar to this one:

The selected document class
requires external files that are not available.
The document class can still be used, but the
document cannot be compiled until the following
prerequisites are installed:
See section (Class Availability) of the
User's Guide for more information.

I'm not sure if the problem is with Lyx itself or some of its Latex dependencies.

I do have the "article.cls" file in my system (from texlive-latex-base) located in:


(This line shows up in Tools → TeX Information, so apparently Lyx knows about it).

I have already tried reinstalling texlive and using Tools → Reconfigure, didn't work.

I'm using LyX in KUbuntu 12.10.

EDIT: Apparently this is a bug in 12.10. I just reverted to 12.04 and everything is working smoothly again, with no setup needed beyond apt-get install lyx.

  • I installed Lyx and it works perfectly.y suggestion would be to reinstall from the software centre but ensure you have the appropriate add ons see selected also. Feb 14, 2013 at 19:32
  • 1
    Please follow the advice in the LyX-Wiki. What happens after the reconfigure-step?
    – qbi
    Feb 15, 2013 at 12:26
  • I have tried those steps already (including running texhash). After reconfigure I just get a message saying that the system was reconfigured and that I must restart Lyx, but nothing changes. I'm actually just about to wipe out my entire system and reinstall ubuntu from scratch, if nothing else works.
    – Znorg
    Feb 15, 2013 at 13:43
  • Change the operating system version? That answer is unacceptable. Does anyone have a real solution to this problem?
    – Nick
    Feb 28, 2014 at 21:11
  • @Nick I can't help, but I confirm that I've been using LyX without problem for the last few versions (and the beta) of (K)ubuntu without problems. So it's definitely possible.
    – Sparhawk
    Apr 9, 2014 at 10:57

4 Answers 4


I know it's an old question, but I just experienced the same problem myself on a fairly recent Mint 17.2 installation.

I used apt-file search article.cls to see which packages have that file - and confirmed that it's present in the texlive-* series of packages. I then did apt-get install texlive - which pulled a few dependencies with it - and the problem was solved.

  • 1
    Can confirm this solved my problem on 18.04 (the package needed was texlive-publishers).
    – kotozna
    Aug 27, 2019 at 0:45

If you only installed the Lyx Processor and Tex-live then you need to extend the functionality of LyX by installing the listed packages (in bold) for full functionality. They are all available in the Ubuntu Software Center.

Those that are NOT in bold are optional (i think they are self explanatory anyway). When i installed these, all my document classes became available.

For additional document classes (subclasses) and other how tos you can visit the Lyx Wiki here

  • chktex: check for typographical errors

  • dvipost: display tracked changes in DVI format output

  • gnuhtml2latex: import HTML documents

  • groff: improved table formatting in plain text exports

  • librsvg2-bin, inkscape: use the SVG image format in LyX documents (if your using Inkscape as your graphics editor inr Lyx)

  • linuxdoc-tools: export SGML LinuxDoc documents

  • mythes-*: use the OpenOffice.org/LibreOffice Thesaurus

  • noweb: import noweb files

  • rcs: integrated version control

  • sgmltools-lite: export SGML DocBook documents

  • texlive-xetex, etoolbox: use the XeTeX typesetting system

  • wv: import MS Word documents

  • I just installed all of these, but I still get the same error.
    – Znorg
    Feb 15, 2013 at 13:36
  • As I have no issues, I am trying to figure out what makes your installation different from mine. I have installed Lyx on many computers with no issues. Did you install it from the USC or from some other source maybe? Feb 15, 2013 at 14:46
  • I first tried the version from the repositories, then the ppa. Both have the same issue.
    – Znorg
    Feb 15, 2013 at 16:13
  • I just came across this question which might be of interest to you. askubuntu.com/review/close/84121 Feb 15, 2013 at 16:57
  • Yeah, looks like it is a bug in 12.10. Thanks for your help.
    – Znorg
    Feb 17, 2013 at 13:51

My new LyX installation showed exactly the same symptoms as the original poster's. I found that there was an old .texmf-var directory in my home directory. Renaming or deleting it, e.g. mv .texmf-var .texmf-var.oldsolved the problem. After that, LyX no longer complains about missing .cls files and compiles documents just fine.

I'm using Ubuntu 12.04, LyX 2.0.7 from https://launchpad.net/~lyx-devel/+archive/release and TeX Live 2012 from https://launchpad.net/~texlive-backports/+archive/ppa.


I don't think the problem is Ubuntu specific. I just installed LyX from the Windows binary installer to WinXP. I have exactly the same symptoms - every time I create a new file (or even when I read documentation, via the help menu) LyX complains about the missing .cls files and that it can display the file but cannot typeset. Here, too, Tools/TeX information neatly lists all the imaginable .cls files as available.

An extra piece of information: I first installed the LyX as an ordinary user, and then it seemed to work - no warnings about missing .cls files. Compilation of an example LaTeX file also worked just fine. However, the installer had complained during the installation that the .WMF and .EMF graphics wouldn't be available, because they require some library which can only be installed as an administrator. So, I uninstalled, logged in as an admin and reinstalled. From that on I have kept receiving the missing .cls file warnings. LaTeX complilation doesn't work, either: when trying to preview the Welcome file, I get the error message
File does not exist: F:/tmp/lyx_tmpdir.gg3264/lyx_tmpbuf4/splash.pdf.

I have not yet investigated the problem much - my first reaction was to search the web to see whether others have encountered the same problem. That's how I ended into this forum.

  • This issue still happens with LyX 2.2.3 on Windows Seven, also it used to work perfectly fine on my machine, it just happens now after updating (both LyX and MikTeX).
    – gaborous
    Feb 4, 2018 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .