question concerning the ufw firewall :

sudo ufw enable


Firewall is active and enabled on system startup

sounds fine, but when i start gufw after reboot, it is still off

what does that mean ? the gui is off and the firewall is running ?

(i know ufw is the command line to set iptables)


It does not matter if you enable or disable the firewall in the terminal, since the *gufw app needs administrative rights it will always open like this:

enter image description here

after you unlock the app with your password then you will see that it is actually active:

enter image description here

This is because the system does not know if the person opening gufw is the same person that enabled the Firewall in the terminal (You might have just walked out of the room to go to the bathroom and a hacker just climbed through the window, ran to your computer and tried to open gufw while you were away). So this is why it asks again, just to make sure.

  • lol. i was seeing the gufw as an extension of ufw but i understand they are 2 differents process. thx for your response. ps. this is another debate, but why the hell is ufw not enable by default at startup in ubuntu ? – riimzzai Feb 14 '13 at 16:24
  • it's actually really bad UI in gufw to display like that - it should say "unknown" or something rather than scaring users. – ImaginaryRobots Feb 14 '13 at 16:26
  • 1
    @riimzzai some users might not like having their firewall set by default since they may need to do stuff with the network or even have their own firewall in the router. Many reasons to simply leave the option of activating the firewall to the user instead of making that decision for them. – Luis Alvarado Feb 14 '13 at 16:27
  • @riimzzai, there is always a firewall in ubuntu called iptables, with several useful (but unrestrictive) rules by default. ufw and gufw are ways of changing the iptables firewall settings rather than being firewalls on their own. – ImaginaryRobots Feb 14 '13 at 16:27
  • ubuntu assumes you are a pro in network security who will activates the firewall at each startup, and windows assumes you are a noob at it. 2 different philosophies. lets hope ubuntu will keep his own one :D – riimzzai Feb 14 '13 at 16:35

When you start gufw it is shown as off, but then when you unlock it, you'll see that it is on.

  • 1
    sure about that. i just feel strange that you have already authenticated once in the sudo ufw command, so why do you have to do it again for the gui ? – riimzzai Feb 14 '13 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.