This question has been asked many times with no answer. I've used my basic Google skills and haven't come across a fix. This is system wide. My mouse simply scrolls too fast.

I'm new to ubuntu and linux in general. Would switching styles or whatever it is called (Ubuntu, KDE, Xubuntu) help at all? Is there a terminal code I can enter?


14 Answers 14


I removed the USB dongle that comes with my wireless mouse and plugged it back and fixed my scrolling speed instantly.

  • 49
    This answer especially applies to a Logitech mouse connected via their Unifying wireless receiver after switching the "smooth scrolling" option in solaar. Commented May 1, 2014 at 4:10
  • 28
    I have a sculpt ergonomic desktop(keyboard & mouse) by microsoft. This solution fixed my problems. Commented Aug 26, 2014 at 19:09
  • 50
    This solution works for Microsoft Mouse too. Commented Jun 25, 2015 at 20:32
  • 8
    Found the perfect solution. No more unplug and plug. Use resetmsmice, or the deb package directly.
    – Ted Feng
    Commented Sep 30, 2015 at 2:09
  • 7
    Not sure if it's relevant, but any idea WHY this works (happened to work for me too, thanks!)?
    – Alan
    Commented Dec 23, 2015 at 1:11

Confirmed working on 20.04:

  1. Install imwheel and adjust (to make things work):
  • Run sudo apt install imwheel
  • Run bash <(curl -s http://www.nicknorton.net/mousewheel.sh)
    • If the above fails, try this alternative address bash <(curl -s https://gist.githubusercontent.com/AshishKapoor/6f054e43578659b4525c47bf279099ba/raw/0b2ad8b67f02ebb01d99294b0ecb6feacc078f67/mousewheel.sh)
  • Using the slider adjust the scroll speed 'multiplier'. (I like it on 4/5)
  1. Add imwheel as a startup application (to make things continue working after restart):
  • Open Apps -> Startup Applications
  • Add a new entry to the bottom of the list: Name= Wheel Scroll Speed, Command= imwheel, Comment= Activates wheel scroll speed fix on system startup (or whatever you like)

Important note:

If you have extra mouse buttons, this might mess things up as far as their functionality. If you find some buttons mis-behaving after following these instructions, you can always go "back" by removing imwheel as a startup application, and restarting your computer.

However, you can still make this work by specifying which buttons to modify in the imwheel command.

imwheel -b "45" this might work for certain mouse types.

imwheel -b "4 5 6 7" this might also work.

In any case, you can try and figure out the button numbers for you own specific mouse scroll wheel, and specify them and only them.

Use the command with button numbers both when running for the first time, and as the command you input as a startup application.

Solution excerpted from here

Important note based on this

  • I don't understand. How to adjust after that?
    – safetyduck
    Commented Nov 18, 2021 at 16:03
  • 43
    It is simply unbelievable that the speed of the scroll wheel cannot be adjusted without external apps in 2022. Commented Mar 1, 2022 at 15:42
  • 2
    The nicknorton.net is down, you can use: bash <(curl -s https://gist.githubusercontent.com/AshishKapoor/6f054e43578659b4525c47bf279099ba/raw/0b2ad8b67f02ebb01d99294b0ecb6feacc078f67/mousewheel.sh)
    – mefmef
    Commented Feb 2, 2023 at 19:46
  • 1
    @Stan Did you mean imwheel -b "4 5" maybe, for Wheel Up (4) and Wheel Down (5)? Commented Oct 31, 2023 at 17:42
  • 1
    @CivMeierFan for me 45 without space worked. But when i typed my previous comment this answer didnt have the last part. Which makes my comment irrelevant
    – Stan
    Commented Nov 1, 2023 at 22:53

To change the mouse parameters:

  • list the peripherals, note the good number with the device name of the mouse!

    xinput list
  • list parameters from peripheral number 9

    xinput list-props 9
  • set the acceleration of peripheral 9 to value 3. The higher the value is, the more you divide the acceleration. Acceleration is maximum for a value equal to 1. The "basis" value seems to be 1.7, for me...

    xinput set-prop 9 'Device Accel Constant Deceleration' 3

To permanently set the change :
A hidden file in your directory is ".profile" (Ctrl+H to see hidden files) Double click on it and open it. Copy paste the previous command at the end. That's it!

P.S. to apply the same command for all users you can edit the file /etc/profile (not an hidden file).

Have fun.

  • 45
    I tried it and this seems to act just on the cursor speed; it has no effect on the scroll wheel behavior.
    – AndreasT
    Commented Jun 25, 2013 at 20:06
  • 3
    I think you're looking for 'Synaptics Scrolling Distance'. Fwiw.
    – zoomix
    Commented Oct 11, 2013 at 20:49
  • 28
    -1 This is about the speed of moving mouse that can changed by default in settings. This is wrong answer to this question! Not about mouse scroll speed. Commented Dec 13, 2015 at 19:22
  • 7
    The correct one is 'Evdev Scrolling Distance', but I can't seem to get it to go faster than 1 1 1.
    – Timmmm
    Commented Apr 4, 2016 at 18:24
  • 28
    Also.. what the hell is this nonsense? The whole point of a mouse is to interact with GUIs, and you're telling me nobody has made a GUI for changing the mouse settings?
    – x0a
    Commented Aug 9, 2017 at 12:14

First check which device is the mouse:

xinput list

Now pick the ID of your mouse there, and list its current settings:

xinput list-props <device-id>

then change the settings like so where Evdev scrolling distance [vertical] [horizontal] [dial]

xinput set-prop <device-id> 'Evdev Scrolling Distance' 1 3 5

where the combination of the last three numbers is mouse-dependent:

  • first number, the direction of scrolling (minus reverse)
  • second number, speed of scrolling somehow
  • third number, speed of scrolling somehow
  • Changing these values to bigger numbers means you scroll slower (AgentME).
  • 9
    this answer would be better if it provided a command to get the settings first, before user decdied to set them Commented Dec 3, 2016 at 2:33
  • 2
    I don't think this answer is generic - if I do "xinput list-props 10" it says the device is "Sleep button" not the mouse, so check to see what device you're altering... Commented Dec 3, 2016 at 3:11
  • 1
    @LéoLéopoldHertz준영 No need, just wanted to clarify what the values mean. Not enough info for an answer.
    – Rtsne42
    Commented Mar 16, 2017 at 17:58
  • 4
    Changing these values to bigger numbers means you scroll slower. If the values are already all set to 1 then there isn't any benefit to touching this setting.
    – Macil
    Commented Mar 27, 2017 at 2:12
  • 40
    I do not have the Evdev scrolling distance parameter
    – Yifan Sun
    Commented May 24, 2019 at 15:03

I have a Logitech PerformanceMouse MX and none of the solutions here worked. The only thing that worked for me was using some parts of this project.

  1. Add this PPA and then install xserver-xorg-input-evdev.
  2. Check out the Solaar project and run rules.d/install.sh. It will copy the udev rules to the appropriate location and ask permissions if necessary.
  3. Remove the receiver and plug it back in.
  4. Add yourself to the plugdev group: $ sudo gpasswd -a <your-username plugdev
  5. Log out and log back in.

Now you can set your scroll-speed with the following xinput commands (source):

$ xinput set-prop <devnum> "Evdev Scrolling Distance" 8 1 1 # for smooth scroll
$ xinput set-prop <devnum> "Evdev Scrolling Distance" -8 1 1 # for smooth 'natural' scroll

Changing the 8 to a lower value increases the sensitivity. Flipping it to negative changes the direction of scroll. Increasing the value decreases sensitivity.

  • 7
    I also have a Logitech Performance MX - on Ubuntu 16.04 just running xinput set-prop 9 'Evdev Scrolling Distance' 3 1 1 solved the problem (9 is my <devnum>). No need to install anything. Add this to your .profile file to apply on login. To get the <devnum> run xinput list.
    – lenooh
    Commented Nov 28, 2016 at 10:20
  • How to do it without smooth scroll?
    – Ferrybig
    Commented Sep 23, 2018 at 16:54
  • 1
    Doesn't work in Ubuntu 20.10 as it is using libinput instead of evdev, plus the mentioned PPA seems to be abandoned.
    – rustyx
    Commented May 23, 2021 at 15:36
  • 1 1 1 is too slow, and I'd like to go faster. Setting any of them to below 1 has no effect (if I ask to read the properties, anything below 1 is simply set to 0!), but setting them higher than 1 definitely slows them down. Any ideas on how to achieve sub-1 values that take effect? Commented Feb 7, 2022 at 23:57

This solution works for me:

sudo apt-get install imwheel zenity

Create a bash script and insert this:

# Version 0.1 Tuesday, 07 May 2013
# Comments and complaints http://www.nicknorton.net
# GUI for mouse wheel speed using imwheel in Gnome
# imwheel needs to be installed for this script to work
# sudo apt-get install imwheel
# Pretty much hard wired to only use a mouse with
# left, right and wheel in the middle.
# If you have a mouse with complications or special needs,
# use the command xev to find what your wheel does.
### see if imwheel config exists, if not create it ###
if [ ! -f ~/.imwheelrc ]

cat >~/.imwheelrc<<EOF
None, Up, Button4, 1
None, Down, Button5, 1
Control_L, Up, Control_L|Button4
Control_L, Down, Control_L|Button5
Shift_L, Up, Shift_L|Button4
Shift_L, Down, Shift_L|Button5


CURRENT_VALUE=$(awk -F 'Button4,' '{print $2}' ~/.imwheelrc)

NEW_VALUE=$(zenity --scale --window-icon=info --ok-label=Apply --title="Wheelies" --text "Mouse wheel speed:" --min-value=1 --max-value=100 --value="$CURRENT_VALUE" --step 1)

if [ "$NEW_VALUE" == "" ];
then exit 0

sed -i "s/\($TARGET_KEY *Button4, *\).*/\1$NEW_VALUE/" ~/.imwheelrc # find the string Button4, and write new value.
sed -i "s/\($TARGET_KEY *Button5, *\).*/\1$NEW_VALUE/" ~/.imwheelrc # find the string Button5, and write new value.

cat ~/.imwheelrc
imwheel -kill


Now run the script and set your desired mouse wheel speed.

Thanks to: http://www.nicknorton.net/?q=node/10

  • 1
    What is Zenity?
    – neverMind9
    Commented May 3, 2018 at 13:16
  • 1
    I found my back and forward keys stopped working :O but otherwise nice Commented May 4, 2018 at 9:57
  • 1
    @neverMind9 Zenity is a dialog creation utility. It is used by the script I pasted above in order to create the mouse wheel speed selector.
    – duli
    Commented May 25, 2018 at 2:13
  • 2
    Change the last real line of the script to say imwheel -kill -b "4 5" and your back/forward mouse buttons will work again.
    – soapergem
    Commented Dec 14, 2018 at 18:15
  • 2
    Daniel - this may or may not work - io.bikegremlin.com/11541/linux-mouse-scroll-speed
    – johndpope
    Commented Apr 23, 2020 at 6:07

I have written a simple script which allows you to find which device has this property ( The script basically iterates over all xinput devices and lists only those which have any property containing scroll).

 xinput list | cut -f2 | cut -f2 -d'=' | xargs -d $'\n' -I'{}' sh -c "xinput list-props '{}' | grep -iq scroll && (echo Listing dev id '{}'; xinput list-props '{}')"
 xinput --set-prop 11 295

Note, that for example in Firefox you can set in about:config


Remember to set


to true.

  • 2
    Thans for that firefox tip. Because adjusting xinput props to 1 is still super sloppy scroll speed. I set my firefox scroll speed to 100 now! :D
    – Ansjovis86
    Commented Apr 7, 2017 at 21:37
  • 3
    Firefox was actually where I wanted to set this, so this is the correct answer for me
    – Amit G
    Commented Apr 9, 2017 at 21:16
  • I found it worked well to change mousewheel.min_line_scroll_amount
    – aardvarkk
    Commented Oct 30, 2020 at 16:08
  • Thank you, This script really works for me. :)
    – Mayur
    Commented Dec 5, 2020 at 19:56

Aside from all of these You can use the old good synaptics dirver for this (Yeah I know it is not supported anymore but lets be honest libinput documentation sucks hard).
If you are on 18.04 or above just install synaptics:

sudo apt-get install xserver-xorg-input-synaptics

now go to /usr/share/X11/xorg.conf.d and just edit the file 70-synaptics.conf

cd /usr/share/X11/xorg.conf.d
sudo nano 70-synaptics.conf

find the section Section "InputClass" Identifier "touchpad catchall" then add these options:

Option "VertScrollDelta" "16"
Option "HorizScrollDelta" "16"

The default number is 26 the lower the number it is faster to scroll, the higher it is slower to scroll. Finally it should look like this:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"
        Option "VertScrollDelta" "16"
        Option "HorizScrollDelta" "16"

Save the file and close it (Ctrl + O then Enter then Ctrl + X).

Log out and back in for the changes to take effect.

Synaptics driver is a driver with huge options I dont know who in a world has decided to move to the NO OPTION libinput.
Other options can be found at:

  • 3
    It's TouchPad scroll speed not mouse scroll speed
    – Voyager
    Commented Jun 19, 2019 at 7:57

Thanks to this new pull request on https://gitlab.freedesktop.org/xorg/driver/xf86-input-libinput/-/merge_requests/12 (WIP: Add scroll distance scale setting ), we will be able to change the scroll speed some time in the future (i.e., after that pull request gets merged and the package xserver-xorg-input-libinput is updated with it) without having to use bugged hacks as imwheel.

For now, you can install it directly from the source code:

  1. WARNING: misconfiguration of an X input driver may leave you without usable input devices in your X session. Use with caution.
    • You can help yourself recover from an input problem by allowing an SSH connection to be performed right after your computer boot. So, if you do not have any usable input on your computer, you can always connect to it using the SSH connection to try and fix the input problem/misconfiguration.
  2. First check which version of xserver-xorg-input-libinput is available on your system:
    1. sudo apt-get install xserver-xorg-input-libinput
    2. dpkg -l | grep xserver-xorg-input-libinput
      ii  xserver-xorg-input-libinput                   0.29.0-1                              amd64        X.Org X server -- libinput input driver
  3. Then, checkout on the git tag as 0.29.0 correspondent to the installed version 0.29.0 on the package manager.
  4. Edit the source code, applying the following patch:
    --- a/src/xf86libinput.c
    +++ b/src/xf86libinput.c
    @@ -1651,6 +1651,7 @@ calculate_axis_value(struct xf86libinput *driver_data,
            value = libinput_event_pointer_get_axis_value(event, axis);
    +   value *= 3;
        *value_out = value;
        return true;
  5. Change the value of 3 on value *= 3; accordingly to how much you would like to change your scroll speed. To reduce the scroll speed, you can use lower values like 0.9, 0.99, 0.2, etc.
  6. After configuring a desired value, build and install your changes:
    1. sudo apt-get build-dep libinput
    2. autoreconf -vif
    3. ./configure --prefix=/usr
    4. make
    5. make install
  7. In order for changes to take effect, you will have to logout and login of your xorg/user session.
  8. To revert your changes, just reinstall the xserver-xorg-input-libinput using your package manager, i.e., sudo apt-get install xserver-xorg-input-libinput --reinstall
  • What do I need to do to enable SSH after boot as you recommended? Commented Jul 28, 2021 at 11:01
  • I'm stuck at the ./configure --prefix=/usr/ step as I get an error xorg-server not found askubuntu.com/questions/1354566/… Commented Jul 28, 2021 at 11:35
  • If you install ssh server, it should automatically startup on boot (cyberciti.biz/faq/ubuntu-linux-install-openssh-server). You can confirm it, installing it and trying to connect to your machine after booting it up. (usually take a minute to ssh service to start up after the boot). Usually, to connect with ssh, you just use your user name (and account password) and machine ip (on your local network) i.e., ssh username@mylocalip
    – user
    Commented Jul 28, 2021 at 15:33

I'm using a "Logitech MAX Master 2". I've tried the solutions in here but what it only works was intalling solaar and modify the configuration through it. Hope this helps.

  • Thank you this tool helps a lot
    – stimulate
    Commented Feb 5, 2022 at 0:31

For Solaar users, the trick was to turn off Scroll Wheel Resolution, i.e. "High-sensitivity mode for vertical scroll with the wheel".



On my ThinkPad, to change the scroll speed using the TrackPoint, inspired by other answers here, I did

xinput list

and found the TrackPoint to be named TPPS/2 Elan TrackPoint. I use the name and not the ID as I found the ID can change on reboot, making. I continued with

xinput list-props 'TPPS/2 Elan TrackPoint'

under which I saw libinput Scrolling Pixel Distance. I set this using

xinput set-prop 'TPPS/2 Elan TrackPoint' 'libinput Scrolling Pixel Distance' x

where x could be values between 10 and 50 (I experimented), lower values meaning faster scrolling.

I finally added the last command in the end of my ~/.profile.

  • For Logitech MX Anywhere mouse, I set: xinput set-prop 12 'libinput Scrolling Pixel Distance' 40 - but I don't see any change. This value was set to 15 by default (which is too fast for me).
    – Danijel
    Commented Jan 16 at 9:25
  • I use the name and not the ID as I found the ID can change on reboot.
    – Rasmus
    Commented Feb 2 at 9:11

My problem was slightly different and I'm posting the answer here to assist other users as well. My issue was that the default mouse hardware added by VmWare Fusion or Workstation was not supporting scrolling in Ubuntu and other Linux distros, while the cursor was moving.

The issue seemed at first to be erratic scrolling, slow scrolling (which lead me here), while in fact, it was a different problem. This thread help me fixed it.


By moving evdev to a later "init" order, the scrolling came back to act as normal.

  • Thanks, but as you are answering a slightly different question, you should have created a new question and answered it yourself. This would be easier to find than through looking at the badly rated answer to a different question.
    – kbenoit
    Commented Dec 19, 2019 at 20:19

Turning the mouse on and off or removing the USB dongle shortly always did the trick for me. However, now it was not working anymore. Neither was the imwheel solution mentioned above a few times. Only after removing solaar the mouse reboot trick worked again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .